Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Odd Category behavior

SOLVED
Go to solution
Highlighted
Scott Slater
Super Collector

Odd Category behavior

Good Morning,

I am experiencing an odd issue with a new service case category I have created.

Whenever I open a form the values for the default template fill in as expected. If I then go to change the category, the new Code I created is not available on the list. Similarly, if I choose a template that is supposed to populate the form with that code, it will not change it. However, once I save the service case and re-open it, the new category code is available to be chosen.

I’m very new at service desk administration so it is entirely possible that there is something I have simply forgotten to do, but I have looked through the admin guide, online resources, and the course materials I have and am not seeing any steps I missed. On the off-chance that there was something buggy with the new category code, I have moved, removed, renamed, and recreated it. I have also purged the cache and restarted the client numerous times during the course of my troubleshooting process.

I am running SD 4.5 SP18. Any insight someone might be able to offer would be greatly appreciated.

Thanks,
3 REPLIES
Michel SILVA SO
Occasional Visitor
Solution

Re: Odd Category behavior

Hi Scott,

could you just verify there is no "Limit Value" UI-Rule in your workflow that shrinks the Code field when a new record is created.

Hope this helps,
Rgds,
Michel
Scott Slater
Super Collector

Re: Odd Category behavior

That would be it.

I must've been staring at those rules too long yesterday in order to have missed that.

Thanks Michel
Michel SILVA SO
Occasional Visitor

Re: Odd Category behavior

;o)
//Add this to "OnDomLoad" event