Service Desk Practitioners Forum
cancel

OVSD Java Error

Highlighted
HP_Tools
Honored Contributor.

OVSD Java Error

Hi!!!

We are getting frequent high utilization problem on OVSD application server. High utilization is due to Java process running on the server. If overall utilization goes more than 75%, OVSD clients becomes too slow. Again, Service Page shows Page cant be displayed.
We are using OVSD 4.5, we are having 3 application server, 2000+ web login users & 150 (approx) client users.
Need help to solve this issue.
Thanks & Regards,
HP Tools

Live as if you were to die tomorrow. Learn as if you were to live forever.
6 REPLIES
Radovan Skolnik
Acclaimed Contributor.

Re: OVSD Java Error

Check your memory settings for Java processes. Default installation has not got enough memory for that number of users. You need to increase the amount of memory available to Java.
Err_1
Acclaimed Contributor.

Re: OVSD Java Error

Hi,

you can use this document to tune your memory settings on your servers.
http://support.openview.hp.com/selfsolve/document/FID/DOCUMENTUM_ITSM005569

Regards;
Randall Barrantes
SW Support Delivery Manager
JaS_4
Acclaimed Contributor.

Re: OVSD Java Error

Check your logserver for out of memory message. If yes, increase your jvm memory, if not, consider adding another server instance if server box has enough evailable memory else consider adding another server box.
HP_Tools
Honored Contributor.

Re: OVSD Java Error

Hi,

Out installserver.bat and sd_server.bat is showing same configuration as suggested in the document. Still it is going to high utilization. Is there any other parameter, i am missing??
Thanks & Regards,
HP Tools

Live as if you were to die tomorrow. Learn as if you were to live forever.
Alexander Kriku
Honored Contributor.

Re: OVSD Java Error


hi

check the values of "threadpool size", "min/max pool size" fields:

1. open the server settings editor and check the value of "threadpool size" field.

2. open the "database accounts" tab, open the db account configuration, select "connection" tab, press "advanced" and check the values of "min/max pool size" fields

according to the number of users, you should modify theese settings.
for example, try to set threadpool size = 60 and max pool size = 63
HP_Tools
Honored Contributor.

Re: OVSD Java Error

Hi,

Threadpoll size was 25, and min/max pool size was 6/16. I have changed these to 60, 6/63 as u said. I will just see the performance and revert back..
Thanks & Regards,
HP Tools

Live as if you were to die tomorrow. Learn as if you were to live forever.