Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

OVIS and Service Desk 5.1 integration

Highlighted
Tom Hag
Super Collector

OVIS and Service Desk 5.1 integration

Hi!

I have installed OVIS metric adapter on my SD application server and by the use of ovc -status I can verify that it is running.

In SD a new metric adapter appears in the menu option "SLM metric adapters".

My problem is that no new metrics are added under OVIS metrics.

If I run:
C:\Program Files\HP OpenView\bin\startMASimulator.bat

Two new test metrics are added to Service Desk.

I am not sure if my metric adapter is able to communicate with my OVIS server. Does anyone now how I can verify this?

Thanks in advance!
7 REPLIES
Carol Hibbard
Honored Contributor

Re: OVIS and Service Desk 5.1 integration

Have you configured the OVIS metric adapter for your OVIS server using the MaConfigGui tool?
Tom Hag
Super Collector

Re: OVIS and Service Desk 5.1 integration

Thank you for your information about the tool.

I have run the tool and added needed information. When I stop and start the metric adapter, the following message appears in the logfile:

Jul 20, 2007 9:03:30 AM;1;10;com.hp.ov.sd.slm.util.SlmLogger;log;com.hp.ov.sd.slm.sa.common.SaException;SEVERE;An Exception with ID=OvisConnector002 LEVEL=CRITICAL occured in component com.hp.ov.sd.slm.sa.ovis.Connector in package: package com.hp.ov.sd.slm.sa.ovis
java.sql.SQLException: [servername]Login failed for user 'ovis'.
at com.inet.tds.a.a(Unknown Source)
at com.inet.tds.a.a(Unknown Source)
at com.inet.tds.a.(Unknown Source)
at com.inet.tds.TdsDriver.connect(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at com.hp.ov.sd.slm.sa.ovis.Connector.onOpen(Connector.java:135)
at com.hp.ov.sd.slm.sa.common.SuperVisor.openConnectors(SuperVisor.java:691)
at com.hp.ov.sd.slm.sa.common.SuperVisor.configure(SuperVisor.java:675)
at com.hp.ov.sd.slm.sa.common.SuperVisor.run(SuperVisor.java:1536)
at com.hp.ov.sd.slm.sa.ovis.OvisMain.main(OvisMain.java:35)


I have tested the login via SQL Query Analyzer and it works fine.

OVIS db is running on a SQL 2005 DB and OVIS version is 6.2.

When I check which versions the adapters support, only 5.2 and 6.0 are included:

Service Desk Service Level Management Metric Adapters
OpenView Performance Manager 5.0 for Windows
OpenView Performance Manager 5.0 for HP-UX
OpenView Internet Services 5.2, 6.0

Could this be the case?

My DB is on an instance on the SQL server, and I have tried the following connections strings:
URL: jdbc:inetdae7:10.30.16.34:144
and
jdbc:inetdae7:10.30.16.34/OVOPS:144

10.30.16.34 = db server
OVOPS = instance on db

and I have also tried:
DBNAME: ovis
and
ovops/ovis

Any suggestions?
Carol Hibbard
Honored Contributor

Re: OVIS and Service Desk 5.1 integration

The OVIS data is stored in the REPORTER database not the OVOPS database.

See pg 254 of the SD 5.1 Administrator's Guide on configuring the OVIS metric adapter.
Tom Hag
Super Collector

Re: OVIS and Service Desk 5.1 integration

The installation is custom and the database name is ovis and it part on DB instance OVOPS.
Carol Hibbard
Honored Contributor

Re: OVIS and Service Desk 5.1 integration

You should point it at the OVIS server not the DB server.

What do you have in the ovisma.xml file in the line?
Carol Hibbard
Honored Contributor

Re: OVIS and Service Desk 5.1 integration

Sorry, I meant to say that you need to point it at the SQL server not the OVIS server. The key lines in the ovisma.xml file are below. You may have issues with using the IP address so you may want to try the MS SQL server host name instead. Also, note that the DBName is hardcoded to Reporter so you'll need to change this for your DB name. I'm not sure from your description if the database is called OVOPS and the login is ovis?:

10
openview
$OVIS_HOSTNAME$
com.hp.ov.sd.slm.sa.ovis.Connector
jdbc:inetdae7:$OVIS_HOSTNAME$:$OVIS_PORT$
reporter
com.inet.tds.TdsDriver
IOPS_DETAIL_DATA

$OVIS_PORT$
openview
10
Tom Hag
Super Collector

Re: OVIS and Service Desk 5.1 integration

OVIS db is not installed on default db instance. After changing from port 1433 to correct port, the integration works!
//Add this to "OnDomLoad" event