Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

No permissions to login to the module Object ServerModule

SOLVED
Go to solution
Highlighted
Eric P_2
Senior Member

No permissions to login to the module Object ServerModule

Dear All,

I'm encountering an issue which not happens everytime, but when it comes out, it's really annoying.

Some of clients suddently cannot log on into the server, and got warning like this:
"No permissions to login to the module Object ServerModule"

Lincese is enough, 20++ concurrent license.

Is any or have have encountered similar problem with me?

THanks,
Eric
16 REPLIES
Ruth Porter
Honored Contributor
Solution

Re: No permissions to login to the module Object ServerModule

Hi Eric,

What version are you using? There was an issue with early versions of 5 which gave this error - these were fixed by SP 2.1 I think.

Hope this helps

Ruth
http://www.teamultra.net
Eric P_2
Senior Member

Re: No permissions to login to the module Object ServerModule

Hi Ruth,

We are using SD 5.x. I'm not very sure it's 5.0 or 5.1. I will get the information soon.

Anyway, where should I find the SP 2.1? I see there is only SP1 for 5.0 patch...

Thanks,
Eric
JaS_4
Honored Contributor

Re: No permissions to login to the module Object ServerModule

Ruth is correct. This is likely the known problem QXCR1000347528 where the concurrent licenses is incorrectly calculated and could also be affected by inbound email which takes up a licenses.
If you check your system*.*.en_us logs, you should find line where the licenses is a negative value.
Number of licenses used: negative number.

This is fixes in sd 5.1 patch 2.1 and above.
If you are on sd 5.0, you will need to upgrade to sd 5.1 patch 2.1 or patch 3(latest).
Eric P_2
Senior Member

Re: No permissions to login to the module Object ServerModule

Hi Jas,

Glad hear this error alredy founded and fix released alredy.

Now I just wondering where to download the Service Packs, the hp website did not have link into it.

Do I have to get this patch from HP support?

Thanks,
Eric
JaS_4
Honored Contributor

Re: No permissions to login to the module Object ServerModule

I get mine from here. http://support.openview.hp.com/patches/sdsk/sdsk.jsp

Just choose the sd 5.1. Note: Make sure you have a copy of your db before starting and choose the upgrade option when prompted.

Eric P_2
Senior Member

Re: No permissions to login to the module Object ServerModule

Hi Jas,

Yes I have been through that page.

SDSK_00143 is this what you mean with service pack?

I'm not sure how HP define service pack and patches.

Can I just install the latest patch (SDSK_00143) jumped from SD5.0 SP1 ?

The dependencies for SDSK_00143 is SDSK_00139 but the information for SDSK_00139 is not available. Did you install SDSK_00139 first and then SDSK_00143 or directly install SDSK_00143 ?

Thanks,
Eric
JaS_4
Honored Contributor

Re: No permissions to login to the module Object ServerModule

Not sdsk_00143 as that is just the patch for the language pack. If you uses localisation, then you will need that and only after applying sdsk_00139. Otherwise, not required.

The patch you want is sdsk_00139 which is for the complete system.

You can just install sdsk_00139 from sd 5.0 sp1. I have done it from sd 5.0 without any issue. But make sure you use the upgrade option. I used the default and ended up with my PC upgraded but my database stayed as sd 5.0 db.
Note: the sdsk_00139 consist of various modules, you will have to upgrade each modules separately. eg servicepages and etc.

good luck.

Eric P_2
Senior Member

Re: No permissions to login to the module Object ServerModule

Thanks a lot, Jas.

I will try all your suggestion.

Regards,
Eric
Eric P_2
Senior Member

Re: No permissions to login to the module Object ServerModule

Hi Jas,

Did you find this error when upgrade-in your system?

I found this and cannot continue the upgrade.

(Screen shot attached)

Thanks,
Eric
Ruth Porter
Honored Contributor

Re: No permissions to login to the module Object ServerModule

Hi Eric,

I had a LOT of problems upgrading and the advice when we asked HP pointed us at some lines at the start of the README.TXT

These are:

Please take the following steps BEFORE the upgrade:
1. Copy the "\packages\guisv_load_settings.bat" to "%OvInstallDir%\lbin\guisv" directory
2. Copy the "\packages\admsv_load_settings.bat" to "%OvInstallDir%\lbin\admsv" directory
Note: %OvInstallDir% means the directory where SD 5.0 PATCH 2 is installed
default would be C:\Program Files\HP OpenView\

When we did this, all went well.

Hope this helps

Ruth
http://www.teamultra.net
Eric P_2
Senior Member

Re: No permissions to login to the module Object ServerModule

Yes

I know about that, it's happened on patch2.

Now I have the patch 3 release (SDSK_00139) which don't have readme.txt and those 2 bat files.

Just wondering if anyone have same issue with me, and how they solve it.

Any idea?

Thanks,
Eric
JaS_4
Honored Contributor

Re: No permissions to login to the module Object ServerModule

Have a look in the Package_msi_HPOvSdMod_install.log and search for "return value 3". Look at the lines above it for the reason that it failed. It may give you the reason there or in the system0.0.EN_US log.
I had no such issue with my patch 3 upgrades, my problem was different.
Eric P_2
Senior Member

Re: No permissions to login to the module Object ServerModule

Jas,

When you run the installer, did the ovsd services are running or stoped? Does this matter?

Thanks,
Eric
Eric P_2
Senior Member

Re: No permissions to login to the module Object ServerModule

My customer haven't come to office yet, I cannot access the server.

Will let you know if I can still find the log.

We did rollback yesterday after the installation failed. then we upgrade to patch 2 and the installation fine.

now we have to use client from patch 3 release in order to connect to server using client.

did you experiencing this problem too before?

Thanks a lot bro for helping,
Eric
JaS_4
Honored Contributor

Re: No permissions to login to the module Object ServerModule

The installer normally do an ovc shutdown during the installation but I am not sure whether the tracing service goes down but most of the HP services goes down.
It auto starts it up again when it finished installing.
I normally don't use the rollback as I had a few bad experiences with rollback where I couldn't reinstall after a rollback. I normally quit and try to get it running from the point of failure or clean out everything if I had to reinstall.
Eric P_2
Senior Member

Re: No permissions to login to the module Object ServerModule

Yes I have bad experience too with rollback.

Modules are uninstalled. lucky I can do reinstall into SD 5.1 patch 2.

I think there are some modules upgraded to patch 3 and some to patch 2, since I have to use client from patch 3 to connect to server.

a lil bit confused now. lucky so far can work.

Thanks,
Eric


//Add this to "OnDomLoad" event