The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

New web-api for HP SD 4.5 SP17 is required

Highlighted
Michael_RU
Occasional Advisor

New web-api for HP SD 4.5 SP17 is required

Dear colleagues,

Our company widely uses HP SD 4.5 SP17. But due to geographical reasons many clients work too slow and waste the time of the engineers. I decided to get familar with java classes automate several time-consuming jobs in SD.

I have downloaded HP SD Starter's Pack and compiled several examples. However, when I try to run them, I fail to establish sessions and exchange data. Here is what happens when I try to use Example1 with correct credentials:

C:\api>java example1 server.name.com:30999 user_account user_password
->Failed reading response from the server.

Here is what happens if logon credentials are incorrect:


C:\api>java example1 server.name.com:30999 user_account incorrect_pass
Access denied: incorrect account name or password. Click OK to retry to log on.

I suggest that communication is OK, but, maybe, api is old or something :(

Could anyone help me with fresh web-api and classes? Also, docs on the usage are very appreciated.

Thank you very much in advance!
6 REPLIES
Vasily Kamenev
Honored Contributor

Re: New web-api for HP SD 4.5 SP17 is required

Hi
Web-api.jar archive need use the same as your SP, the documentations about classes located in the SP too.

Vasily
Michael_RU
Occasional Advisor

Re: New web-api for HP SD 4.5 SP17 is required

Vasily,

Thank you very much!
Actually it is not that easy to request web-api for SP17 in our company as it is world-wide and I am not sure where I can find HP SD admins... is there any way to download them from the Internet?
Vasily Kamenev
Honored Contributor

Re: New web-api for HP SD 4.5 SP17 is required

Hi
Look that. Beliave not moer doc from HP about.

Vasily
Michael_RU
Occasional Advisor

Re: New web-api for HP SD 4.5 SP17 is required

Vasily,

Thank you again!
I have found allmost docs in hp SD 4.5 Starter's Pack, but I have a problem:

C:\api>java example1 server.name.com:30999 user_account user_password
->Failed reading response from the server.

I think that happens because those api and classes are from HP SD 4.5 but our server runs HP SD 4.5 SP17 with upgraded api. That seems to be a point of incompatibility.

Could you, please, adv. me where I can get hp SD SP17 api? It seems that I only need full "api" folder from hp SD SP17 installation disc.

Thanks again!
Vasily Kamenev
Honored Contributor

Re: New web-api for HP SD 4.5 SP17 is required

Extract SP and in \api folder stored web-api.jar file, in \doc\Web API javadoc\ saved documentation for this achive.

Vasily
Michael_RU
Occasional Advisor

Re: New web-api for HP SD 4.5 SP17 is required

Vasily,

I am sorry, but SP17 upgrade came to us in .msi package as incremental upgrade. I have looked through .msi and .cab files of the upgrade, but did not find web-api.jar or java classes inside - it seems that those files were prevoiusly excluded.

It would be really hard to contact development and web-support team...

Is there any way I could download web-api + classes from Internet?
//Add this to "OnDomLoad" event