Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Moving the HP Service Desk application server

SOLVED
Go to solution
Highlighted
Colleen Talbert
Collector

Moving the HP Service Desk application server

We are getting ready to move the physical server to a CoLo off site, but doing so will require a new IP address for the server.

I have heard conflicting answers about whether or not the licenses need to be updated with the new IP Address before we can move it.

Can someone please clarify? Will my application server still work if we give it a new IP Address?

Thanks,
Colleen
4 REPLIES
Err_1
Honored Contributor
Solution

Re: Moving the HP Service Desk application server

Service Desk licenses are not attached to the server's IP address.

What you will need to do after changing the IP is to:
1. Make sure that app & DB server can communicate to each other
2. Make sure that all SD clients can communicate to your new app server.

Regards;
Randall Barrantes
SW Support Delivery Manager
The Pike
Honored Contributor

Re: Moving the HP Service Desk application server

SD4.5 licenses are not tied to IP addresses and AFAIK, neither are SD5.10 licenses.

You need to make sure the rep_servers table in the SD database does not contain a row pointing to the server with the old IP.

Points for the contribution are welcome.

The Pike
Radovan Skolnik
Honored Contributor

Re: Moving the HP Service Desk application server

There is an IP address field in the license file (encoded) but usually contains "*.*.*.*"

Also I believe the IP address is not checked by SD application server. It wouldn't make sense - you can have as many application servers running in load balancing setup as you want. Which IP to check then?

So I'd say it's pretty safe to move it.
Colleen Talbert
Collector

Re: Moving the HP Service Desk application server

Whew! I didn't think so, but the guy who used to maintain the system (over 4 years ago) put the fear in our minds. I forgot to mention that we're running 4.5, so we should be all set. I will check the rep_servers table as suggested, though.

Thanks for the quick replies!
//Add this to "OnDomLoad" event