Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Mandatory field doesn't work in SD 4.5 SP18

Highlighted
Maximo 5
Regular Collector

Mandatory field doesn't work in SD 4.5 SP18

Hi,

I want to configure a custom fiel(type date time) for the closed and resolt estatus but it doens't work.

Anybody help me please?
View attach
8 REPLIES
Mark O'Loughlin
Honored Contributor

Re: Mandatory field doesn't work in SD 4.5 SP18

Hi,

you could try another approach.

Use a UI rule to force a stop notification on close of the call if the date field empty with the condition set to the status that you require this to fire on.

Should work while you look into why the mandatory fields do not appear to work.

Raghunathan Tik
Frequent Visitor

Re: Mandatory field doesn't work in SD 4.5 SP18

Hi Maximo,

it is observed on SP18 that, the mandatory field will work but will not get highlighted immediately after setting that field as mandatory to a selected field.

to overcome from this, just exit from your client once and then relogin to see its actual behavior.

raman
Maximo 5
Regular Collector

Re: Mandatory field doesn't work in SD 4.5 SP18

I restart the client and clear the caché but not work.

I am a UI rule for to informed field when estatus = "Resolt" but with option of "Update All" the UI Rule doesn't work.
Raghunathan Tik
Frequent Visitor

Re: Mandatory field doesn't work in SD 4.5 SP18

Hi Maximo,

this is the common problem. you may still have a fix to this.

create similar rule (that you created under UI) under DB Rule. this would definately solve your issues.

Raman
Raghunathan Tik
Frequent Visitor

Re: Mandatory field doesn't work in SD 4.5 SP18

also, attached is the sample UI & DB Rule that I have created that permorms the same function. The DB RUle will work if the calls are updated using UPDATE ALL function, else UI Rule will trigger if single SC is modified.

raman
Maximo 5
Regular Collector

Re: Mandatory field doesn't work in SD 4.5 SP18

I can't because I can closed a SC without selected the status "resolt" by means of the option "Update All". I need mandatory field
Raghunathan Tik
Frequent Visitor

Re: Mandatory field doesn't work in SD 4.5 SP18

hi Maximo,

i am sorry to tell you that this is the most irritating thing with me as well. me too having the same issue but its unfortunate that i cannot solve this issue.

to overcome this, what i do is strictly instruct the users not to use Update All and close the Call.

raman
Raghunathan Tik
Frequent Visitor

Re: Mandatory field doesn't work in SD 4.5 SP18

Hi Maxim,

in continuation to the previous threads, i would say that this behavior is definately by core ovsd design and has no workaround. However an enhancement request may be logged and can wait what the developers have to comment.

raman
//Add this to "OnDomLoad" event