The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Mails not getting delivered

Highlighted
Harini.G
Collector

Mails not getting delivered

Hi,

We are working on SD4.5 with SP4.

The problem is that some mails are not getting delivered to users. The error is :
"501 Syntax error in recipient address"
This problem has occured only recently that is from around 3 days.

Can somebody kindly help me.

Rgds
Harini.G
5 REPLIES
Ramaprasad N
Esteemed Contributor

Re: Mails not getting delivered

Are the email addresses populated properly in all the person records?? From the error indicated above, looks like email address mentioned in the person record could be wrong/.

-Ram
Harini.G
Collector

Re: Mails not getting delivered

Hi Ramprasad,

Thanks for your reply.

I had logged a test call for the person and the mail was delivered and i didnt get the error.

But when a mail trigerred from a DB rule, I get this error. Can you pls help me. I am attaching the log details for this error.

Rgds
Harini.G
Raghunathan Tik
Frequent Visitor

Re: Mails not getting delivered

Hello Harini,

I see a comma (,) sign after the email id (i.e. ,<>). Try removing the comma sign.

raman
Raghunathan Tik
Frequent Visitor

Re: Mails not getting delivered

also try to specify the email ID directly in the DB rule rather than allowing DB rule to pick from the person record and check.

raman
Ramaprasad N
Esteemed Contributor

Re: Mails not getting delivered

If you want to add multiple email fields in the email template/action, please use the ";" to separate these email attributes/addresses.

-Ram
//Add this to "OnDomLoad" event