Service Desk Practitioners Forum
cancel

Mail Alerts not working..Points Assured...

Highlighted
Pramod Raghaven
Outstanding Contributor.

Mail Alerts not working..Points Assured...

Hi

We have SD 4.5 with SP 21 installed on Windows Server 2003 with Sql as the backend database. All of a sudden our mail alerts have stopped working. I dont see any error in the log file mentioned but the mail does not reach the recepients..

Please help me out of this problem... In case if you require any information do let me know...

Regards,
Pramod Raghavendra
"If you are good at doing something never do it for free"
9 REPLIES
Ruth Porter
Acclaimed Contributor.

Re: Mail Alerts not working..Points Assured...

Hi there,

When you say "mail alerts" do you mean system generated emails or just those from DB rules?

If all (inc system) emails, then does a test email work?

If just DB ones, do they involve scheduled tasks? If so, how many scheduled tasks do you have?

Finally, have you got email debug switched on? If not, turn it on and see if there are any error messgaes.

Regards, Ruth
http://www.teamultra.net
Pramod Raghaven
Outstanding Contributor.

Re: Mail Alerts not working..Points Assured...

Test mail is working fine...

But the mails from DB rule does not seem to work...

"If you are good at doing something never do it for free"
Ruth Porter
Acclaimed Contributor.

Re: Mail Alerts not working..Points Assured...

Hi there,

Do the DB rules involve scheduled tasks?

If so, how many scheduled tasks do you have?

You can hit problems if you have "too many"

You could try restarting the services and see if that helps.

Regards, Ruth
http://www.teamultra.net
Pramod Raghaven
Outstanding Contributor.

Re: Mail Alerts not working..Points Assured...

Hi,

There arent many scheduled tasks

One more thing is the alerts are coming intermitent

Some time alerts come for the condition and some time the alerts do not come.

Yeah restarted all the services and checked but no luck..

Regards,
Pramod
"If you are good at doing something never do it for free"
Ruth Porter
Acclaimed Contributor.

Re: Mail Alerts not working..Points Assured...

Hi there,

You may need to put rule debug an so that yu can see exactly what is happening.

Regards, Ruth
http://www.teamultra.net
Pramod Raghaven
Outstanding Contributor.

Re: Mail Alerts not working..Points Assured...

Hi

Thanks for the help.
Can you just help me through how to enable rule debug

Regards,
Pramod
"If you are good at doing something never do it for free"
Ruth Porter
Acclaimed Contributor.

Re: Mail Alerts not working..Points Assured...

Hi there,

Go to Tools>System>System panel>General settings and you will see a check box for rule debug.

Note your logserver.txt may get VERY large so be prepared to stop the service, rename it and restart to keep the size down.

Hope this helps, Ruth
http://www.teamultra.net
Pramod Raghaven
Outstanding Contributor.

Re: Mail Alerts not working..Points Assured...

Hi

Thanks for the reply.
Let me just check it for sometimes and then will come up with the observation

Thanks for the support provided...

Regards,
Pramod
"If you are good at doing something never do it for free"
Pramod Raghaven
Outstanding Contributor.

Re: Mail Alerts not working..Points Assured...

Hi,

I am closing this thread.

The problem was one address to which the relay was not happening from the mail server was creating the problem.

So removing it from the DB rule fixed the issue.

Regards,
-Pramod
"If you are good at doing something never do it for free"