Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Java problems (SDClientBean) after upgrading Service Desk 4.5

Highlighted
Helge Langholm
Regular Collector

Java problems (SDClientBean) after upgrading Service Desk 4.5

Hi all,
After upgrading ServiceDesk 4.5 from SP15 to SP23 some javascripts does not work anymore. SDClientBean seems not to be able to log on to the system anymore.
The system runs om Windows 2003 SP1, with Java 1.4.2_4 istalled.
Does anybody have some idea on how to resolve this problem?

Best regards
Helge
2 REPLIES
Mihai Tita
Occasional Visitor

Re: Java problems (SDClientBean) after upgrading Service Desk 4.5

Hi,

1. Taking into account that HP recommends Java 1.4.2_15 for SP23, try to use this version.

Otherwiswe,
a long way:

1. Deinstall and install your browser

or

2. Download and install Windows Script from Microsoft

For Windws XP
http://www.microsoft.com/downloads/details.aspx?FamilyID=47809025-d896-482e-a0d6-524e7e844d81&DisplayLang=en

Regards,
Mihai


Helge Langholm
Regular Collector

Re: Java problems (SDClientBean) after upgrading Service Desk 4.5

The problem was caused by the application using an old version of web-api.jar. The developer had copied the file into a new catalog which the application was using. When upgrading Service Pages as a part of service pack 23 the file became obsolete. After copying the new file to the catalog used by the application everything worked as a charm.

Rgds
Helge
//Add this to "OnDomLoad" event