Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Incoming mail with multipart

Highlighted
Laszlo Sipos
Occasional Advisor

Incoming mail with multipart

Hello!

I need an urgent help.
We have upgraded servicedesk 4.5 from patch 22 to patch 25.
There are customers which create service calls by e-mails.
Customer sends an e-mail with multipart/alternate mode which is containing only one part ,
the body of the e-mail does not copy it into the Information field of servicecall. Information field remains empty.
Content-Type: multipart/alternative;
boundary="----=_Part_351_31778523.1201696680411"
------=_Part_351_31778523.1201696680411
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain; charset="ISO-8859-2"
Here is the body of e-mail.
------=_Part_351_31778523.1201696680411--


It seems that servicedesk takes only the second part of the multipart, putting it into the information field.
If we put an extra boundary with the same context like part one with index, we can see, that the second part goes to Information field.

If multipart/alternate mode contains both
Content-Type: text/plain
Content-Type: text/html
The html part goes to Information field.

This problem does not appear in SP22.
Is this a bug in SP25?
Is there any hotfix, solution to this?

Thanks in advance.
Laszlo

1 REPLY

Re: Incoming mail with multipart

Hi Lazlo.

A quick test on our system seems to confirm that HPOV SD 4.5 SP25 discards multipart e-mails. SP21 does not.

No Service call at all is registered in our test SP25 system when e-mail is multipart.

Could someone else verify this?

Michael
//Add this to "OnDomLoad" event