Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Inbound email not working

Highlighted
Sharon F. Santi
Collector

Inbound email not working

hi,

Im configuring the inbound email for SD 4.5 SP15. I'v seen almost all the post here but can't find similar setup as to what our client have. Here's the setup:

SD server: sdserver.companydomain.com
SD System Panel email setup:
email server: exchange.companydomain.com
inbound email address: servicedesk@companyemaildomain.com

Noticed that the SD server and the inbound email address have different domain(companydomain for sdserver and companyemaildomain for email).

So, what i did was to create a SMTP connector that will allow the email sent to servicedesk to be forwarded to SD server.

When the smtp connector was created and the routing service for exchange was restarted Iv tested if a new service call will be created by sending to this email address servicedesk@sdserver.companydomain.com, however I got a system undeliverable message saying this email address never exist.

I'v successfully configured inbound email at the lab having the same domain for SD server and email domain and same config for the connector, but for our client it didn't work.

What else do I need to configure? Does anyone been successful doing this having the same setup? Need help.

Thanks,
Sharon
6 REPLIES
Mark O'Loughlin
Honored Contributor

Re: Inbound email not working

Hi Sharon,

the inbound email address:servicedesk@companyemaildomain.com should not be qualified in the admin console.

The inbound email address should be set to :servicedesk (based on your details provided above.

what ever is to left of the @ symbol should be se as the inbound address in the admin console.

What ever is to the right of the @ shoul dbe defined letter for letter in the exchange connector.

Does this help?
Sharon F. Santi
Collector

Re: Inbound email not working

Hi Mark,

I already did what you said but still with no success. I can't even send to servicedesk@sdserver.companydomain.com I always got an undeliverable message saying No user here.

I tried using the Test Mail from the email settings of SD and tried sending to servicedesk@sdserver.companydomain.com and its ok. but from the log file of SD, here's what i got:

Tue, 31/01/2006 14:16:36 SMTPERRORjava.net.SocketTimeoutException: Read timed out
at java.net.SocketInputStream.socketRead0(Native Method)
at java.net.SocketInputStream.read(Unknown Source)
at java.io.BufferedInputStream.fill(Unknown Source)
at java.io.BufferedInputStream.read(Unknown Source)
at com.hp.ifc.net.smtp.AppMIMEInputStream$BoundaryChecker.readCommand(Unknown Source)
at com.hp.ifc.net.smtp.AppMIMEInputStream.readCommand(Unknown Source)
at com.hp.ifc.net.smtp.AppSmtpRequestHandler.process(Unknown Source)
at com.hp.ifc.net.tcp.AppTcpConnection.processRequest(Unknown Source)
at com.hp.ifc.net.tcp.AppTcpThread.run(Unknown Source)

Tue, 31/01/2006 14:16:36 Ended parsing duration: 637739 ms
Tue, 31/01/2006 14:17:45 Started parsing E-mail
Tue, 31/01/2006 14:17:45 Ended parsing duration: 125 ms
Mark O'Loughlin
Honored Contributor

Re: Inbound email not working

Hi Sharon,

Admin Console System Panel - Email - E-mail Commands
Select a command e.g. New and choose to modify
For testing set the Access Level to unrestricted (no check on E-mail address) and see if an e-mail with the new command in the subject fielf gets delivered
David Borojevic
Frequent Visitor

Re: Inbound email not working

Hi Sharon,

I'm a bit confused but this is how I have linked SD and our exchange system.

Inbound email tab - ServiceDesk (no @...) as mentioned above.

Use New command as default and take restrictions away as suggested - make sure template provides all required fields.

On exchange side I created a connector as you have done but for the email domain @servicedesk.companyemaildomain.com. Then create in the Active Directory a CONTACT that has the address ServiceDesk@Companyemaildomain.com AND ServiceDesk@ServiceDesk.Companyemaildomain.com with the latter being set as the primary SMTP address. Exchange will then accept email to ServiceDesk@Companyemaildomain.com and will magically forward it to ServiceDesk@ServiceDesk.CompanyEmailDomain.com.

This is nice because the end users can use the ServiceDesk@CompanyEmailDomain.com and it will be in the GAL.

Cheers
Sharon F. Santi
Collector

Re: Inbound email not working

Hi,

I'v already successfully configured the inbound email for SD and can now create service call via email. Thanks for all your responses.

I just have another question, how an email message with HTML format be logged as service call to SD? Having the email in plain text format is ok, however in HTML format is not. Iv noticed that when I try to send using HTML format a service call ID was created (ID sequence appends)however it is not visible in SD. Why is this so and where does the service call goes? Is there's a way to make this possible? cause most of the end users uses this format in Outlook.

Thanks!
David Borojevic
Frequent Visitor

Re: Inbound email not working

Hi Sharon

In ESM under Global Settings I have created an Internet Message Format "Service Desk Emails" for our Service Desk email domain that has the following:

Message Encoding: Mime: Provide Message Body as Plain Text.
Character Sets: Mime: US ASCII
Character Sets: Non-Mime: US ASCII
Exchange RichText Format: Never Use

These settings will deal with HTML OK - the HTML version of the message will appear as an attachment to the Service Call.

Also good to turn off automatic replies,forwards, out-of-office assistance delivery reports etc for this domain. Turning all of this off helps prevent loops.

//Add this to "OnDomLoad" event