Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Inbound Mails are not working

SOLVED
Go to solution
Highlighted
MSEMEA
Regular Collector

Inbound Mails are not working

Hi,

we have implemented SD 4.5 with SP15 and we want to use inbound emails for registering a new service call.

I tried the following I have telnet the server on port 25 everything fine. I have take a look at the server log and found the following message:

Wed, 25/01/2006 11:03:27 SMTPERRORjava.io.InterruptedIOException: Read timed out
at java.net.SocketInputStream.socketRead(Native Method)
at java.net.SocketInputStream.read(Unknown Source)
at java.io.BufferedInputStream.fill(Unknown Source)
at java.io.BufferedInputStream.read(Unknown Source)
at com.hp.ifc.net.smtp.AppMIMEInputStream$BoundaryChecker.readCommand(Unknown Source)
at com.hp.ifc.net.smtp.AppMIMEInputStream.readCommand(Unknown Source)
at com.hp.ifc.net.smtp.AppSmtpRequestHandler.process(Unknown Source)
at com.hp.ifc.net.tcp.AppTcpConnection.processRequest(Unknown Source)
at com.hp.ifc.net.tcp.AppTcpThread.run(Unknown Source)

Wed, 25/01/2006 11:03:27 Ended parsing duration: 600000 ms

May be someone knows what to do?

Thanks
24 REPLIES
Misaq
Honored Contributor

Re: Inbound Mails are not working

Have you registered the inbound email address ?
Milan Bucko
Super Collector

Re: Inbound Mails are not working

You create person in SD with inbound email equals inbound email for registering a new service call.
MSEMEA
Regular Collector

Re: Inbound Mails are not working

I have registered the mailadress for inbound mailadress. But may be I did something wrong, how can I check that?
MSEMEA
Regular Collector

Re: Inbound Mails are not working

@Peter What sense does it make to create a person with the same mailadress like the mailadress for inbound mail. For inboundmail I have configured a mailbox.
Milan Bucko
Super Collector

Re: Inbound Mails are not working

MSMEA If you want registered SC,so you have to do.
MSEMEA
Regular Collector

Re: Inbound Mails are not working

I want the serviedesk to create a ticket if a mail comes in the mailbox ..... with the command new
Mark O'Loughlin
Honored Contributor

Re: Inbound Mails are not working

Hi,

you don't set this function up this way. The mails have to be forwarded directly to the Openview server and not a mailbox for these comand to work. If the server is correctly configured and the e-mail has the correct command in the subject field then it will work (provided a few other steps has been taken).

You need to have your e-mail system be able to route e-mails to your service desk server.
This means setting up an inbound e-mail address n the control panel-Email and having you e-mail server have a entry to route this address to the OVSD server

Can you confirm the steps that you have taken so far.

MSEMEA
Regular Collector

Re: Inbound Mails are not working

sorry for the late answer, I have been asking other cooleagues what you might mean by "The mails have to be forwarded directly to the Openview server and not a mailbox for these comand to work. " nobody realy understand. Is that mean I have to have a mail server on the same machine. I do not think so or am I wrong.
jamxav
Regular Collector

Re: Inbound Mails are not working

Hello MSEMEA,

Yes, Mark is right and yes, OVSD already includes an email server.
You will have to configure which port OVSD's smtp will be using, but by default is 25. You may want to disable the SMTP service that is available as part of the OS or change OVSD's SMTP port. Try doing a "telnet 25" and see what svc is answering.

Also take in mind that FWs may bring additional sources for issues when testing email integration at the beggining.

Mark O'Loughlin
Honored Contributor

Re: Inbound Mails are not working

Hi,

sorry about that. I'll try again.

Openview can accept e-mails but you need your e-mail server (Outlook / Notes) to have a record to point to both the email address specified as the inbound address and the openview server IP address. This defines the routing path from your e-mail server (Outlook / Notes) to the Openview server. Once the mail can be routed to the openview server with an appropiate command it should be able to process it.

You do not need a mail server installed on the openview server.

i hope this is a little clearer
MSEMEA
Regular Collector

Re: Inbound Mails are not working

telnet gives the following answer
......is ready for input
MSEMEA
Regular Collector

Re: Inbound Mails are not working

Thanks in advance for your help guys, but I dont understand how should a record point to both an mailadress and an ipadress, can you give an example...sorry I dont get it

Here is what I have; my server with the SD Server is installed on a machine which is migrated in the network and I have installed Outlook and can reach my Mailbox with that outlook installation. I have entered the adress of the mailbox as inbound mailadress.

BUT NO SUCCESS...
Bhuvnesh
Frequent Visitor

Re: Inbound Mails are not working

Hi,
As mentioned in above threads, service desk uses its own SMTP server (enabled in server settings).So all incoming emails should be sent to this SMTP server only.
Suppose your server's FQDN is x.abc.com then you can configure helpdesk@x.abc.com as the email address in email settings screen of service desk system panel.
Now if you send any email to helpdesk@x.abc.com in the correct format, a call should get logged.
But your users might be having an email id as y@abc.com that means their email address will be that of your company domain and all emails will go to your domain's email exchange server.Which will not know how to handle mails for x.abc.com domain.
For this, you will have to configure a connector in exchange which can route mails for x.abc.com to your service desk server (which is already running SMTP).
You can follow these steps to configure a connector in exchange:
â ¢ Open Exchange System Manager (ESM) console and navigate to the Connectors Container.
Note: If you canâ t see the Administrative Groups you have to go into the properties of the Exchange Organization object and enable the view of â Administrative Groupsâ and â Routing Groupsâ .
â ¢ In the Context Menu of the Connector Container click New â â SMTP Connectorâ .
â ¢ Give a name (ex: Exchange to Helpdesk)
â ¢ Select â Use DNS to route to each address space on this connectorâ .
â ¢ Select "Forward all mail through this connector to the following smart hosts" and enter service desk server's FQDN (i.e. x.abc.com).
Note: If you want to specify IP then IP address of the Smart Host must be specified in Brackets (this prevents Exchange from trying to resolve the IP Address with DNS).
â ¢ In Address Space for the SMTP Connector select address Space type as â SMTPâ and in Address field specify Service desk server's FQDN i.e. x.abc.com
â ¢ In Connector scope select "routing group" for connector scope, and check "Allow messages to be relayed to these domains".
â ¢ In content restriction page uncheck â System Messagesâ .

Apart from this setting, you also have to ensure that all incoming emails are sent in plain text. (Service desk will not be able to process emails in HTML or rich text format). This can be ensured by defining an internet message format for the service desk email domain (x.abc.com).Steps are:
â ¢ In the left pane of Exchange System Manager, double-click to expand the Global Settings icon, and then click Internet Message Formats.
â ¢ Right-click Internet Message Formats, point to New, and then click Domain.
â ¢ Enter a descriptive name for the object such as Mail to Servicedesk, and then type the SMTP domain x.abc.com
â ¢ Click the Message Format tab. Click MIME, and then click Provide message body as Plain Text.
â ¢ Select US ASCII character set for both MIME and Non-MIME messages.
â ¢ In Advanced tab select never use exchange rich text format.
â ¢ Click OK to accept the settings, and then close the properties dialog box.


Note: All the steps mentioned above are relevant for MS exchange 2003. If you are using a different email server, then steps may vary.

Hope this helps.

Regards,
Bhuvnesh

Re: Inbound Mails are not working

Hi all,

Forgive me if I'm being a bit silly here, but doesn't the fact that there is an entry in the SD Server Log at all mean that email IS hitting ServiceDesk.

If there was a problem with email routing and the mail wasn't getting sent to SD, there wouldn't be anything in the log file.

So for what it's worth, I think that the things to check would be :-

Is there another SMTP service running, if you telnet to port 25 on your server and you get a response similar to "ServiceDesk 4.5 SMTP" then you're talking to the right port. If not, then I'd guess that there's another SMTP service on that port. If you're on a windows server, check the services that are running and see if there's another email service active. If there is, disable it and restart the SD App server.

Can you use SMTP commands to send an email - a simple set of commands to use when telnetted onto the server would be :-

helo server.name.com

mail from:

rcpt to:

data

THIS IS A TEST

.

After this final "." an email is sent into servicedesk. Don't forget to put the "<" around the email addresses either.

Next off, how have you configured inbound email on ServiceDesk ? I'm a little mixed up between versions, but I know for certain that in SD 5.0 the inbound email address should NOT be fully qualified, i.e. instead of "servicedesk@yourcompany.com" you just need to enter "servicedesk" and ignore the "@yourcompany.com" part. Its been a while since I did this on 4.5 so I'm not totally sure that this is correct, but it won't hurt to try.

Finally, does OUTBOUND email work OK ?

Just my two euros worth !

Dave C.
Marc Hummel
Frequent Visitor

Re: Inbound Mails are not working

If using exchange, create redirector on the exchange server(if you don't know how to do this get with your exchange admin and explain what you are attempting, they will know how to configure a redirector) to point back to ovsd server. make sure mail account exists and is tied to a template for the command.
Wounds heel, Pain fades... chix dig scar's, oh and everybody WangChung.
Mark O'Loughlin
Honored Contributor

Re: Inbound Mails are not working

Hi,

the inbound email address should NOT be fully qualified in 4.5 however it needs to be fully qualified in the mail server (Exchange Connector).
MSEMEA
Regular Collector

Re: Inbound Mails are not working

So many answers!!! Thanks

OK the telnet on port 25 works

Outboundmail also works

What I have also tried I worte a mail to servicedesk@ipadress from a client. After 6 hours I received a mail saying: ****** Message from InterScan Messaging Security Suite ******

The following mail could not be delivered.
Reason: Unable to deliver message to .
Mark O'Loughlin
Honored Contributor

Re: Inbound Mails are not working

Hi,

can you attach screen grabs of the e-mail settings within the admin console
MSEMEA
Regular Collector

Re: Inbound Mails are not working

I attached the mail settings
Mark O'Loughlin
Honored Contributor
Solution

Re: Inbound Mails are not working

Hi,

Hi,

the first tab looks ok ref outbound and general settings.
Ref the Inbound E-mail settings tab:
remove the @bearingpoint.com from the address and leave just bpt-fmdehelpdesk. In here you just specify the name of the address to the left side of the @xxx.xxx

You now need to go to your mail server (exchange or notes I think your running exchange) and have a connector created (listed previously in this thread) to be able to route mails addressed to bpt-fmdehelpdesk@bearingpoint.com to be routed to the Openview server. In this connector you specify the IP address of the Openview server.

Note: We had to create a new @xxx.xxx address so that we only routed these internal mails to the Openview server so that all the @xxx.com mail was not directed to the Openview - the mail admins had concerns here.

When you send a mail to openview you will send it to bpt-fmdehelpdesk@xxxxx.xxxxx

bpt-fmdehelpdesk= defined in the Inbound E-mail address
@xxxxx.xxxxx = Defined as a roupe to an ipadress or node in your e-mail exchange server

I hope this is clear for you.
MSEMEA
Regular Collector

Re: Inbound Mails are not working

ahhhh....now its getting somewhere I think now I understand. See what I can do, since the exchange stuff is not in my hand ....I let you know

And THANKS A LOT
David Borojevic
Frequent Visitor

Re: Inbound Mails are not working

Hi there,

I just noticed that your from address and reply to address are the same. If you make these different you can protect from an email loop. ie. If you get an incoming email form a valid caller and it creates a service call, and a confirmation email goes back to caller, then you get an out of office auto reply, a new call is logged (or call is updated) - and you have a loop. Out-of-office replies will automatically return to the from address whereas if a user replies manually it goes to the reply address.

It is a good idea to have a different from address. You could get the from address setup as a email enabled public folder so that you can still capture things going to it without a risk of a loop.

Other protection can be done at the exchange level by disallowing forwards and auto-replies and system messages to your service desk email domain. Your exchange team should know what to do. If not see

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=996514

Hoope that makes sense/helps?
OVSD SSL connec
Acclaimed Contributor

Re: Inbound Mails are not working

Hi,

Can I please have a copy of screen dumps for setting up mail in Excahnge 2003. AD is used with 1 domain. Oubound mail works fine but inbound is not hitting the SD log files, so error is on the Exchange side. Much appreciated. daniel.zmood@zmood.id.au.
Marc Hummel
Frequent Visitor

Re: Inbound Mails are not working

quickie:

set up person w/ account you want to use.

tools/system/email - create inbound email address, match with inbound template, make sure IP address range allowed (* will allow all as will leaving it blank) On exchange create mailbox (not hidden) create redirector and point to OVSD app server that is config'd for port 25 (check server settings editor) send test mail.

hth
Wounds heel, Pain fades... chix dig scar's, oh and everybody WangChung.
//Add this to "OnDomLoad" event