The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Inbound Email not working

Highlighted
Eric Bohr
Regular Collector

Inbound Email not working

I am using SD 4.5. I believe that my outbound email is working because I can receive emails when I use the SEND TEST MAIL. I am quite confused with the Inbound Email. I created a mail account servicedesk@first-datacorp.com. I placed servicedesk (without @first-datacorp.com)in the Inbound Email Address and linked this with a template. I do not know how to test it properly but I tried to use my email account and emailed the servicedesk@first-datacorp.com. I typed NEW in the subject line of my email. A service call is not created. I looked at my logserver.txt and noticed that I have an error "SMTP Service on port 25 disabled. Error: Address in use: JVM_Bind. I need help.
25 REPLIES
Mikhail Ivanov
Honored Contributor

Re: Inbound Email not working

Hi.

Try disabling Windows SMTP service.

Misha.
Eric Bohr
Regular Collector

Re: Inbound Email not working

Hi Mikhail,
The SMTP is started already however service calls are still not created. Did I miss out something?
Vahur Huntsaar_
Collector

Re: Inbound Email not working

Well,

try running: telnet your_sd_server_ip 25
if you can connect than SMTP service is working on your ServiceDesk server.

Can you clarify a bit? This servicedesk@first-datacorp.com is a mail account in your e-mail server and not in servicedesk server?
If so, then your servicedesk servers hostname is something like servicedesk.first-datacorp.com?
And if so try to send an e-mail to servicedesk@servicedesk.first-datacorp.com.

However i might of undersood you wrong, so correct me if i wrote nonsense.

All the best,
Vahur
It's a zoo out there!
Joseph Madden
Collector

Re: Inbound Email not working

Eric,

This may qualify as a 'check to see if it is plugged in' type of suggestion, but you might want to check the server configuration SD45=>application server=>open the server settings editor, click the SMTP tab and make sure SMTP is enabled and you don't have any weird filters in place. It sounds like the email is getting to your sd server (which can be a big step in and of itself).

If this is too simple-minded, my apologies.

Joe
Eric Bohr
Regular Collector

Re: Inbound Email not working

Hi Vahur,
Yes I can connect using the telnet service. My Application Server name is tcutstsrv01.first-datacorp.com. My mail account is servicedesk@first-datacorp.com. I tried to email servicedesk@tcutstsrv01.first-datacorp.com but my email just bounced back. I followed everthing in the documentation but still it is not working.
Vahur Huntsaar_
Collector

Re: Inbound Email not working

Eric,

whta do you mean: bounces back? Is it the same thing as before (logserver.txt shows the same error?)?

If so, than i have only one more thing i can think of you could try. I remember form SD4.0 times, that in order for inbound e-mails to work one needed an according application user account. So that, if you wanted to send e-mail to servicedesk@sd_server_hostname.domain.com you had to have an sd application account with login servicedesk (can be integration account). I don't know when this requirement was made obsolete, but at least in SD4.5 SP4 this is no longer neccesary.
Anyway, when you test, i think it's allways wise to send e-mails directly to something@sd_server_hostname.domain.com - then look at logserver.txt again and if you get a NDR reply, examine its contents.

Hope this is of any use,
Vahur
It's a zoo out there!
Mikhail Ivanov
Honored Contributor

Re: Inbound Email not working

Eric,

DISABLE Windows SMTP service.
Disable means stop it.

:-)

Misha.
Vahur Huntsaar_
Collector

Re: Inbound Email not working

Ahaa...
Mishas last comment made me look again to other messages in this thread, and your seccond message sais that SMTP service is allready started?
Under no circumstances should Win2k SMTP service run on SD app. server, SD has it's own SMTP service. So as Misha said, if your win2k SMTP serive is running, stop it and disable it.
Vahur
It's a zoo out there!
Eric Bohr
Regular Collector

Re: Inbound Email not working

Hi Vahur,
I already disabled the Win2k SMTP service. I also tried to email sd_server using the email servicedesk@sd_server_hostname.domain.com but still no service calls was created. Also there is no logs registered in the logserver.txt. I also added an Application Account but still no progress. I attached the bounced back email.
Vahur Huntsaar_
Collector

Re: Inbound Email not working

Eric,

this attachment shows, that your e-mail server can't resolve your servicedesk servers hostname.
On that case, this has nothing to do with SD actually since the e-mail just doesn't arrive to SD server at all.
I really don't know then how you could be able to get the errormessage in your logservet.txt that you mentioned in your first message.
To you have your own e-mail server, or is your company using some outside service provider. It looks to me, that your e-mail ended up in an outside e-mail server, that naturally can't solve your sd servers hostname.
So basically you need to look at e-mail servers properies.
Sorry, that i can't be of more help,
Vahur
It's a zoo out there!
Eric Bohr
Regular Collector

Re: Inbound Email not working

Hi Vahur,
Yes I believe that the email is not routed to my Application Server. I am not familiar with MS Exchange. Do you have any suggestions how to configure my email server?
Vahur Huntsaar_
Collector

Re: Inbound Email not working

Well,

i'm no Exchange specialist myself, but i think i can give you a few guidelines. You must have a connector in MS Exchange that takes care of your sd servers subnet(or the sd server itself). In Exchange System Manager, right-click Connectors->New->SMTP Connector.
In General tab, write a name and i thik you must specify your exchange server as the local bridgehead (just click the add button and select the appropriate server). Also see that 'Use DNS to route to each address space on this connector' is selected (just in case).
Then you must select the Address Space tab and add a new address space (click add and select SMTP). I believe in your case it should be exactly as follows:
*tcutstsrv01.first-datacorp.com
Attention! '*' as the first sign is mandatory.
I think you must select the 'Allow messages to be relayed to these domains' checkbox (it's also on Address Space tab).
I think thats about it.
If it doesn't work, i can dig a little deeper if you want, but first try this.

Best regards,
Vahur
It's a zoo out there!
Eric Bohr
Regular Collector

Re: Inbound Email not working

Hi Vahur,
I followed everything you've instructed but still inbound email is not working. My suspicion still is the messages emailed to servicedesk@first-datacorp.com is not routed to SD server. Do you have other suggestions? Really appreciate your help.
Vahur Huntsaar_
Collector

Re: Inbound Email not working

Just a quick question.
In your last message, you say that e-mail sent to servicedesk@first-datacorp.com is not routed to SD server. Is that e-mail address correct? Or is it a typo?
As i understand this servicedesk@first-datacorp.com is an e-mail address in your Exchange? If yes then you must forward e-mails sent to this address to SD, thats why i asked you to send e-mails directly to SD server: servicedesk@sdserver.domain.com.

Before you got NDR back when you sent an e-mail to servicedesk@sdserver.domain.com, is that so now? If not, then is there anything in logserver.txt now?

Vahur
It's a zoo out there!
Eric Bohr
Regular Collector

Re: Inbound Email not working

Hi Vahur,
The email address servicedesk@first-datacorp.com is the email account in my Exchange Server. I also tried using the servicedesk@tcutstsrv01.first-datacorp.com but still I receive NDR. Still there is nothing in logserver.txt.
Vahur Huntsaar_
Collector

Re: Inbound Email not working

Is it the same NDR as befor, or has something changed in it?

Vahur
It's a zoo out there!
Vahur Huntsaar_
Collector

Re: Inbound Email not working

Oh, and one more thing.
Is your SD server first-datacorp.com domain member at all?
It's a zoo out there!
Eric Bohr
Regular Collector

Re: Inbound Email not working

Hi Vahur,
The NDR is the same. My SD Server is a member of the domain. Any suggestions?
Vahur Huntsaar_
Collector

Re: Inbound Email not working

Earlyer i suggested that you should try telnet sd_server_ip 25 (did you get the access denied message when you did taht?).
Just in case try also 'telnet sd_server_hostname.domain.com 25' or 'nslookup sd_server_hostname.domain.com'
And also just in case change the address space in that exchange connector to:
*.first-datacorp.com
Just in case, this should be done only for the duration of test, since i dont know your organizations e-mail stategy.

Vahur
It's a zoo out there!
Carlos Aguilar_
Regular Collector

Re: Inbound Email not working

Hi Erick
Do you solve your problem?
I have same problem
Matthew Wright_
Occasional Advisor

Re: Inbound Email not working

Eric,

Did you ever get this working? I have the same issue - have an HPSERVICEDESK email account set up on our Exchange server. Outbound mail works fine. Can't get inbound mail to work, tried all of the things that you tried.

What's the resolution? I can't beleive that this is an uncommon problem! The HP Service Desk manuals say very little on how to set up inbound e-mail.

Thanks!
Eric Bohr
Regular Collector

Re: Inbound Email not working

Hi Carlos & Matthew,
I still can't find the solution.
Franz_8
Regular Collector

Re: Inbound Email not working

nebody.. any updates... is it working..
valentin_8
Occasional Contributor

Re: Inbound Email not working

I tried ,same as you,everything and it's not working....
Could any of you really use that option to create,update..,a call with Inbound e-mail that HP ServiceDesk supose to have?
Is it a bug..? It need's something else to be installed,like an update or a patch...or something?
//Add this to "OnDomLoad" event