Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Inbound Email cannot find ID

SOLVED
Go to solution
Highlighted
Ariffin Kusetia
Occasional Contributor

Inbound Email cannot find ID

I have setup the inbound e-mail in Service desk 4.5. For help and list command it works fine. But if I try other command like view 1234, the system responded with

The given ID not found: 1234

I would be grateful for any help or suggestion.

13 REPLIES
Jonathon Druce
Honored Contributor

Re: Inbound Email cannot find ID

What is the setup for the view command? Is there a Service Call with an id 1234? Is the view command set up to be available? Is it also set to only respond to known people or anyone. Post the setup of the command (system - system - email - comands)
Ariffin Kusetia
Occasional Contributor

Re: Inbound Email cannot find ID

Hi Jonathan,
All the test IDs are valid. The view command was set-up for unrestricted access.Pls refer to attachment1.
Thank you in advance.
Jonathon Druce
Honored Contributor

Re: Inbound Email cannot find ID

Does the system account use a thousands seperator? If so remove it.
Ariffin Kusetia
Occasional Contributor

Re: Inbound Email cannot find ID

I have disable the , symbol. Right now the message "Service Desk did not recognize this command". It howeve still work for help and list commands.
Jonathon Druce
Honored Contributor

Re: Inbound Email cannot find ID

Make sure there is a trailing space in the view command. IE in the are that you took the screen dum make sure the command is "view " not 'view'.
Ariffin Kusetia
Occasional Contributor

Re: Inbound Email cannot find ID

Hi Jonathan,
Tq for ur patience. I have tried that as and many other combinations, all to no avail. It just seems that whatever ID supplied, the system would not find in database.
The command is working because if i did not enter an id the system responded with

You must specify an ID

I am really confused now. the manual mentioned modifying sd.conf . Do I need to and if so where is this file cause I couldn't find it in the system.

Again thank you veru much
Jonathon Druce
Honored Contributor

Re: Inbound Email cannot find ID

Anything in the server logs
Ariffin Kusetia
Occasional Contributor

Re: Inbound Email cannot find ID

Hi Jon
I don't see any partcular error message that suggest the rootof the problem, but i attach it anyway, for ur perusal.

TQ in advance
Mike Bush
Honored Contributor

Re: Inbound Email cannot find ID

These problems seem to be spreading! I have a site with exactly the same symptoms (SP15) and am unable to explain (an SQL trace even shows the call being retrieved so the failure is somewhere in the code which decides to allow the VIEW or UPDATE).

AND there is now a Known Error for a very similar issue := ITSM008029 which may suggest SP15 has problems - and yet my test SP15 system is working fine! Watch this space!
Mike Bush
Honored Contributor
Solution

Re: Inbound Email cannot find ID

Eureka! - (but no running down the street naked). I have finally cracked this by comparing a working system with a failing one.

The VIEW and UPDATE commands both fail IF YOU HAVE NO LICENCE FOR SLM MODULE

I shall report to HP ASAP
jamxav
Regular Collector

Re: Inbound Email cannot find ID

Hello Mike,

Did you tell HP about this limitation on not having SLM module? I just replicated that error on a customer and I don't think this is a planned limitation...

Diego
Mike Bush
Honored Contributor

Re: Inbound Email cannot find ID

For anyone hitting this - it is ITSM008029 and MAY be fixed in SP17 (I've not tested this yet)
Ariffin Kusetia
Occasional Contributor

Re: Inbound Email cannot find ID

Hi all,
I habe check with our implementor and she confirmed that the problem should be resolved with the service pack 17, although I am not sure when that would be available. Meanwhile, somehow she had managed to make the new command works. I wouls like to thank all of you that had replied to my postings, they were all very helpful.
//Add this to "OnDomLoad" event