Service Desk Practitioners Forum
cancel

Inbound Email Configuration

SOLVED
Go to solution
Highlighted
Mohammed Albust
Honored Contributor.

Inbound Email Configuration

Hello all,

I'm facing a problem creating service calls via emails. I've configured the outbound Email settings and it's sending test emails successfully. I've created a new email address and linked it to one of the templates. I made sure that all the required fields in the template are filled out. Email commands are set up and access level is set to no restriction.

Could anyone think of something that is missing?
23 REPLIES
jconsola20
Outstanding Contributor.

Re: Inbound Email Configuration

What errors are you receiving when trying to create a Service Call and what release are you at?
Mohammed Albust
Honored Contributor.

Re: Inbound Email Configuration

Thanks for your response,

OVSD 5.0. I'm not getting any errors. It is just not creating service calls. I checked the emails that were sent to that email address and they were all recieved.
Ruth Porter
Acclaimed Contributor.

Re: Inbound Email Configuration

Hi there,

Do you have email debug switched on (OV Config>System Settings>Email settings)? If not, switch it on and then try again. see what messages appear in the log file - they should tell you where the problem lies.

Hope this helps

Ruth
http://www.teamultra.net
Mohammed Albust
Honored Contributor.

Re: Inbound Email Configuration

Thanks Ruth,

Email debug is switched on. I was looking for the log file in HP openview folder but couldn't find it. what could possibly be the reason if all settings are cofigured correctly?
Ruth Porter
Acclaimed Contributor.

Re: Inbound Email Configuration

Hi there,

The log file is by default in C:\Program Files\HP OpenView\data\log and if you order by date, you should see files with names like systemN.0.Lang where N is number and Lng is the language code (e.g. en_GB for me).

Open the most recent and search for line sbeginning SMTP

Hope this helps

Ruth
http://www.teamultra.net
jconsola20
Outstanding Contributor.

Re: Inbound Email Configuration

Are the emails being forwarded to the smtp server of the application server? Whatever email application you have (Exchange, Lotus Notes) needs to be configured to forward those emails to the smtp server.
Marc Hummel
Outstanding Contributor.

Re: Inbound Email Configuration

Yes, emails must be past onto OVSD via the actual email app. Also when creating the inbound email addresses in OVSD, DO NOT add @.com if the name of the address is john@gg.com just enter john as the inbound address.

good luck.
Wounds heel, Pain fades... chix dig scar's, oh and everybody WangChung.
Mohammed Albust
Honored Contributor.

Re: Inbound Email Configuration

The emails are being forwarded to SMTP server but still not creating service calls.

This is what I have in the log file
Apr 10, 2007 4:59:23 PM;10;12;com.hp.ov.obs.impl.util.AppLog;log;com.hp.ov.obs;INFO;: Send mail to: mohammed_albustami@dima.com.jo
Apr 10, 2007 4:59:23 PM;11;12;com.hp.ov.obs.impl.util.AppLog;log;com.hp.ov.obs;INFO;: Server : smtp.jdcs.jo port: 25
Apr 10, 2007 4:59:23 PM;12;12;com.hp.ov.obs.impl.util.AppLog;log;com.hp.ov.obs;INFO;: From : mohammed_albustami@dima.com.jo
Apr 10, 2007 4:59:23 PM;13;12;com.hp.ov.obs.impl.util.AppLog;log;com.hp.ov.obs;INFO;: From alias :
Apr 10, 2007 4:59:23 PM;14;12;com.hp.ov.obs.impl.util.AppLog;log;com.hp.ov.obs;INFO;: Reply to :
Apr 10, 2007 4:59:23 PM;15;12;com.hp.ov.obs.impl.util.AppLog;log;com.hp.ov.obs;INFO;: CC :
Apr 10, 2007 4:59:23 PM;16;12;com.hp.ov.obs.impl.util.AppLog;log;com.hp.ov.obs;INFO;: BCC :
Apr 10, 2007 4:59:23 PM;17;12;com.hp.ov.obs.impl.util.AppLog;log;com.hp.ov.obs;INFO;: Subject : Subject of test mail
Apr 10, 2007 4:59:23 PM;18;12;com.hp.ov.obs.impl.util.AppLog;log;com.hp.ov.obs;INFO;: Attachment : C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\1\testAttachment.txt
Apr 10, 2007 4:59:23 PM;19;12;com.hp.ov.obs.impl.util.AppLog;log;com.hp.ov.obs;INFO;: Body : Body of test mail
Apr 10, 2007 4:59:23 PM;20;12;com.hp.ov.obs.impl.util.AppLog;log;com.hp.ov.obs;INFO;: Characterset: US-ASCII
Apr 11, 2007 7:39:46 AM;21;13;com.hp.ov.obs;WARNING;Unexpected null requester received.
JaS_4
Acclaimed Contributor.

Re: Inbound Email Configuration

I noticed that your subject does not have the NEW keyword in it.
You can trigger the inbound email NEW template either via the word NEW in the subject field or making the NEW command the default command.
Check if you have NEW command as the default.
Mohammed Albust
Honored Contributor.

Re: Inbound Email Configuration

this is the log for the outbound test email.
the inbound email log is not even showing in the log file.
JaS_4
Acclaimed Contributor.

Re: Inbound Email Configuration

Email to create new service calls are handled by the inbound email section of Service Desk. The outbound email section handles replies and notification from SD. The outbound email are not related to handling processing inbound email for creating new servuice calls.
Make sure you have SMTP turn on for your SD 5.0.
From an Outlook client, sent an email to your SD 5.0 server. If your SMTP port 25 is turn on, it will process that inbound email and create a new SC.
Make your mail network recognise the SD 5.0 server as a valid SMTP server and will route inbound emails to it.
Mohammed Albust
Honored Contributor.

Re: Inbound Email Configuration

I installed SMTP service on the application server. I think this has made a conflict and now the Object server is not initializing properly. Is there anyway to go back?
JaS_4
Acclaimed Contributor.
Solution

Re: Inbound Email Configuration

You do not need to install SMTP service, SD comes with SMTP functionality. You can just turn it on via the edit server settings.
Try undoing what you did which was uninstalling the OS SMTP and restarting ovc. The installation of OS SMTP should not affect the server, it would conflict on port 25 with SD inbound email if you already have SD's own SMTP turned on.

Mohammed Albust
Honored Contributor.

Re: Inbound Email Configuration

Now I uninstalled OS SMTP, cleard the Object Server cashe and the application server is running back again. Let's get back to the initial point which is not being able to create service call via email.
JaS_4
Acclaimed Contributor.

Re: Inbound Email Configuration

You really should go through the admin guide as the bit about SD's smtp is all mentioned in there.
If you click on start, hp openview, edit server settings, protocols tab, choose stmp, make sure enable protocol is on and the port 25 is used.
Hopefully, that's the reason why your inbound email is not working. If I remember correctly, the smtp and the http is off by default.
Mohammed Albust
Honored Contributor.

Re: Inbound Email Configuration

ITP, HTTP, SMTP are all enabled with the correct ports. I've gone through the guide step by step. configured email settings,configured the templates, linked them to commands, set the restriction access, created new email for service desk.
Anything I'm missing?
Marc Hummel
Outstanding Contributor.

Re: Inbound Email Configuration

Did you remove the @whatever_company.com from the inbound email address specified in the admin console?

eg. if the email you use is support@xxx.com DONT enter the entire string, enter ONLY support for the inbound.
Wounds heel, Pain fades... chix dig scar's, oh and everybody WangChung.
Ruth Porter
Acclaimed Contributor.

Re: Inbound Email Configuration

Hi there,

I have not read every single line of all this but would like to make 2 points:

1. Is you email server forwarding emails to the HPSD server on the specfiied port?

2. If it IS, then you should see SMTP messages in the logfile AND if a new call is not logged you should recieve a message saying "your email has not resulted in a call being logged ..."

Are you sure that your emails erver is passing on the messages?

Hope this helps

Ruth
http://www.teamultra.net
Mohammed Albust
Honored Contributor.

Re: Inbound Email Configuration

Hi Ruth,

Thanks for the response.

regarding forwarding messages from the mail server to the application server, all I can see that when I configure outlook for example on the application server i can pull all the emails. but i don't see any log in the log file indicating incoming messages.
Ruth Porter
Acclaimed Contributor.

Re: Inbound Email Configuration

Hi there,

If your email server is passing on the relevant emails to the HP SD application server then if you have email debug switched on then you will see an entry in the SD logfile.

If there is no message in the SD logfile then the most likely explanation is that the message is not reaching the SD server. Reasons for this could be that the email sever is not passing them or perhaps there is something like an Anti virus blocking them. The main point is that is it is an issue outside HPSD and you need to look elsewhere.

Hope this helps

Ruth
http://www.teamultra.net
Mohammed Albust
Honored Contributor.

Re: Inbound Email Configuration

Thank you Ruth for the clarification,

The problem was in the exchange server. The server was actually not passing the messages to service desk.
Solution: A connector was established in the exchange server to forward the messages and that did the job.
Saqibj
New Member.

Re: Inbound Email Configuration

Hi Muhammad,
I was reading your case and please let me know one thing: is your SD server stand alone(work group) machine or on domain by which you are sending mail to Inbound Email addresses users. becasue i am still facing inbound problem, Email is not being sent through exchange server because we are confused about the domain where to send the mail, my server is the HP-UX and standalone.
kindly share to me some thing.
regards,
saqib
Ruth Porter
Acclaimed Contributor.

Re: Inbound Email Configuration

Hi saqib

You do bets to log a new thread because when a thread is closed people don't look at them

Ruth
http://www.teamultra.net