Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Inactive sessions (>2000) residing the Service Desk Database

Highlighted
Kim Holden
Super Collector

Inactive sessions (>2000) residing the Service Desk Database

Afternoon Everyone :)

I was wondering if anyone can provide some information on the above issue we have. Its not causing any real concern at the moment, but we seem to have way too many inactive sessions residing on our database and we were wondering whether we should do something about it or not.

Firstly, we have 22 Service Desk Windows Application servers (SD 4.5, Service Pack 21), and we run an Oracle Database. We have 2500 concurrent licences, with normally around 450-500 users logged in at once.

The 2000+ inactive sessions are there even when only 1 or 2 users are logged in. When we stop the services the inactive connections automatically disappear. However, when we restart the services, the inactive connections automatically re-appeared

We have been advised that this could be because of our Minpool and Maxpool settings.

Our current settings on each of our 22 servers is:

Min Pool :40
Max Pool :51

So my questions are:

1. Would this account for the 2000+ inactive sessions on our database?
2. If so, would you have any recommendations about adjustments we could make?
3. Has any one else had this sort of issue and come across problems with changing them?
4. What would you recommend the settings be if we change them?
5. Has anyone had any problems with adjusting these settings that we should know about?

Your help would really be appreciated :)

Thanks!

Kim :)
6 REPLIES
Radovan Skolnik
Honored Contributor

Re: Inactive sessions (>2000) residing the Service Desk Database

Kim,

first of all - WOW - such a large implementation. This is something that provides possibility to test the platform extensively. Are you satisfied with scalability/performance, etc.? Any plans to migrate to SM (I hope not - I can't imagine the HW required for that)?

To your issue: I do not really have solution - just check out inactivity timeout settings in SD. But you say that when you shutdown app servers and then restart the connections re-appear? Is there any pattern in them? I.e. all from the same host or something like that?

Best regards

Radovan

P.S.: Please have a look at this: http://www.skolnik.info/sdutils/sso/readme.html You may find it useful...
Gurevich
Member

Re: Inactive sessions (>2000) residing the Service Desk Database

If PC with running SD client is blocked (not logged off) and SD client has option "autorefresh each ## minutes" - it will be active session on SD server. I have ~5-10 ghosts like this. May be it`s the cause?
Kim Holden
Super Collector

Re: Inactive sessions (>2000) residing the Service Desk Database

Thanks for the comments :)

Radovan - I'm not 100% sure, but I think we are the largest installation of Service Desk, or if not the largest, we are definitely up amongst the biggest :)

So far we are very happy with the scalability and performance :) As for migrating to SM - thats up to the powers that be LOL!

I will definitely check out the inactivity settings, perhaps that has something to do with it also :)

As for a pattern, I don't believe so. Though I'm not sure anyones looked for a pattern yet - I'll add that to my list of things to do also.

Gurevich

Thanks for that - I'll check into the ghost theory also :)

Anyone else have any ideas?
Mike Khashan CA
Super Collector

Re: Inactive sessions (>2000) residing the Service Desk Database

Kim,

If there are entries in the â Logged on usersâ this means there are connections initiated from the PC where sd clients are installed to sd application servers. You can highlight them and mark them for removal. SD applications will remove them after few seconds. If they reappear again, this means the connections are still initiated from the PCs so ensure users to kill jview.exe process on their PC's or reboot the PC. if still for some reason they reappear again here is what you can do during the maintenance window of SD:

By using to sql do:

(delete from rep_sessions where ses_created = )
PS: don't remove your active session.
Peter Foreman
Regular Collector

Re: Inactive sessions (>2000) residing the Service Desk Database

Hi Kim,
If it is the auto refresh on SD client that is causing the inactive connections try:
Tools; System; SystemPanel; GeneralSettings;
Un-tick the box for EnableAutomaticRefreshInterval

Gurevich
Member

Re: Inactive sessions (>2000) residing the Service Desk Database

So what was the problem?
//Add this to "OnDomLoad" event