The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Importing Service Desk data and adding existing attributes (Category) on SD 5.0

Highlighted
Jacqueline Godb
Occasional Contributor

Importing Service Desk data and adding existing attributes (Category) on SD 5.0

Hi,

Is it possible, when importing data into service desk to add default value of attributes that doesn't exist in the source data? For example, I am loading data from Radia that is related to the 'Software' category in Service Desk. In Radia, the field 'Category' doesn't exist, so it is not exported. But when I load the data from the .xml, can I add the default Category to each field? I have read in the data exchange administrator book, and it doesn't specify how to do this.

Can you help?

Thanks,
Jacqueline
2 REPLIES
Jonathon Druce
Honored Contributor

Re: Importing Service Desk data and adding existing attributes (Category) on SD 5.0

There are a couple of ways;

1) During the export add a literal. For example 'Software' as [Category] (Using single or double quotes depends on the ODBC driver)

2) During the import - add the value into the template being used to import the item.

Hope this helps.
Jacqueline Godb
Occasional Contributor

Re: Importing Service Desk data and adding existing attributes (Category) on SD 5.0

Thanks Jonathon,

I will try to first option, but I would have liked to use the second option.

Can you please explain where in the template you add the value when you import if I am to use the second option? For example, when I choose the Category field or attribute in the IM (Import Mapping) menu, it allows me to choose the Category option on the bottom right, but it also wants to have the external attribute value; since I don't have Category in the source, I don't have a value for the external field. So how do I do it?

Thanks a million,
Jacqueline
//Add this to "OnDomLoad" event