Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

How to get Example1.java up and running with SD4.5(SP18)?

SOLVED
Go to solution
Highlighted
jaume
Super Collector

How to get Example1.java up and running with SD4.5(SP18)?

Hi,
we are using SD4.5(SP18) with jdk1.3.1_17.
And We have the next error while running up Example1.java:

com.hp.ifc.io.AppStreamException: Unable to deserialize an object.

Before jdk1.3.1_17, We tried with j2sdk-1_4_2_10 but the error is the same.
There is no error while compiling the file.
Any suggestion? Thanks for advance,
Jaume
5 REPLIES
jaume
Super Collector

Re: How to get Example1.java up and running with SD4.5(SP18)?

I attach a log file found in C:\
Gyula Matics_1
Honored Contributor
Solution

Re: How to get Example1.java up and running with SD4.5(SP18)?

Make sure you are using the version of web-api.jar is the same as the version of the server. Each service pack includes a new web-api.jar
jaume
Super Collector

Re: How to get Example1.java up and running with SD4.5(SP18)?

yes, that works!! the jar file in server was newer than in client. i have changed the file in client and now works. but may I change the java version from jdk1.3.1_17 to j2sdk-1_4_2_10 in client (server uses j2sdk-1_4_2_10)?

thanks a lot and regards,
jaume
Gyula Matics_1
Honored Contributor

Re: How to get Example1.java up and running with SD4.5(SP18)?

SP18 is the first version that officially supports java 1.4, so yes, you can use j2sdk-1_4_2_10.

Be aware that 1.4.2.10 has performance problems. 1.4.2.9 or 1.4.2.11 is better.
jaume
Super Collector

Re: How to get Example1.java up and running with SD4.5(SP18)?

thanks again and i close the thread.
regards,
jaume
//Add this to "OnDomLoad" event