Service Desk Practitioners Forum
cancel

HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

SOLVED
Go to solution
Highlighted
Marty Brown_1
Super Contributor.

HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

Hi all:

We are running HPSD 4.5 SP21. Our company is moving from a Lotus Notes email infrastructure to Exchange 2007.

With our new Exchange 2007 email server, we are finding that inbound email to HPSD that contains attachments is not able to be processed successfully by HPSD like it was in Lotus Notes. The sender of the email receives an email back with an error message like the one below:

Error when put file C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\tmp\4-rr.log;size=61;creation-date=Thu, 21 Dec 2006 08:51:12 GMT;modification-date=Wed, 20 Dec 2006 14:00:20 GMT!#! to attachment server: java.io.FileNotFoundException: C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\tmp\4-rr.log;size=61;creation-date=Thu, 21 Dec 2006 08:51:12 GMT;modification-date=Wed, 20 Dec 2006 14:00:20 GMT!#! (The filename, directory name, or volume label syntax is incorrect)

We have email debug turned on, and below is a cut/paste from the HPSD server log of the “attachments” information from the email message that is failing:

Mon, 18/02/2008 10:14:48 Attachments: [(content.html : C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\tmp\2-content.html!#! : text/html;charset=us-ascii), (content.txt : C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\tmp\3-content.txt!#! : text/plain;charset=us-ascii), (rr.log;size=61;creation-date=Thu, 21 Dec 2006 08:51:12 GMT;modification-date=Wed, 20 Dec 2006 14:00:20 GMT : C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\tmp\4-rr.log;size=61;creation-date=Thu, 21 Dec 2006 08:51:12 GMT;modification-date=Wed, 20 Dec 2006 14:00:20 GMT!#! : application/octet-stream;name=rr.log)]

Compare this with a cut/paste from the HPSD server log of a Successful/No Errors “attachments” entry from back when Lotus Notes and not Exchange 2007 is the originator:

Tue, 05/02/2008 11:52:23 Attachments: [(content.html : C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\tmp\15-content.html!#! : text/html;charset=US-ASCII), (content.txt : C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\tmp\16-content.txt!#! : image/gif), (content.txt : C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\tmp\17-content.txt!#! : image/gif), (drivez.log : C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\tmp\18-drivez.log!#! : application/octet-stream;name=drivez.log)]

It looks like Exchange 2007 is adding details about the file (Creation Date, Modification Date, Size, etc.) in a format that HPSD doesn’t understand, and it is being interpreted as part of the file name, which is causing the extraction of the attachment from the email message to the HSPD server's C drive to fail.

I’m assuming that others have run into this before, since I’m likely not the first person to try to point Exchange 2007 at HPSD 4.5. Does anybody else have experience with this and know of a workaround or hotfix available (either to Exchange or to HPSD 4.5) that would get us around this issue?

Thanks!

~Marty
17 REPLIES
Marty Brown_1
Super Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

Turns out that this has already been submitted as an Enhancement Request, and will be part of Service Pack 26:

http://support.openview.hp.com/selfsolve/document/LID/ITSM009366

:-)
Vasily Kamenev
Acclaimed Contributor.
Solution

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

HI Marty.
Yes the problem in additional infromation in Attachment line.
If you trust me, you can you attached file by next way:
- if you are not use hotfix for server - extract this file, rename to hotfix.jar
- if you are already use hotfix for server -
extract this file, rename to hotfix.jar, extart classes from this file and from your hotfix to one folder, then compress all classes files to one hotfix.jar
Stop the application server, save hotfix.jar to lib folder, start the server. Enjoy.

Vasily
Marty Brown_1
Super Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

Vasily: BLESS YOU!! I added this hotfix.jar to my test server, and I can now successfully send emails with Attachments and Embedded images to it from an Exchange 2007 email server! Works Great!!

This hotfix will save me the WEEKS of work that I was looking at if I had to migrate everything to SP26.

A question: Is anything in this hotfix SP-level dependent? Meaning, Is a particular vintage of Web-API part of the compile?

I'm trying to re-open this thread so that I can give you some points, but it's timing out. I'll keep trying.

THANKS AGAIN!!!
Vasily Kamenev
Acclaimed Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

Hi
Thanks for point. This hotfix not related with web-api, the fix overload the original class of HP, at principal this hotfix alreade HP class, but add some rows to correct the problem and copiled. The class used only by SD incoming e-mail server, but web-api classes not containe classes about. Beliave aswer on you question.

Vasily
chappers
Frequent Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

Hi Guys,

You mentioned that this Hotfix worked for you - with which Service Pack(s) has it worked? HP currently only have a Hotfix for this for SP23. I'm hoping it works with SP25.

Thanks.
Marty Brown_1
Super Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

This hotfix from Vasily worked on my HPSD 4.5 SP21 application.

~Marty
Vasily Kamenev
Acclaimed Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

HI
You can try it, I'm use on SP23, but this class not changing more time and beliave will working on 24,25 too.

Vasily
Bradley Richman
Frequent Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

How can I get this hotfix?
Bradley Richman
Frequent Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

How can I get this hotfix?
bradley.richman@iowa.gov
Thanks
Marty Brown_1
Super Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

Bradley: The bits you seek are attached to the third message in this thread, in a message from Vasily Kamenev. Enjoy!
Georgia.Chaliko
New Member.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

Hi,

I am experiencing the same issue although we have SP22, will the hotfix mentioned help me, if so, how can I get it

Thanks
Georgia
Vasily Kamenev
Acclaimed Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

Hi
The file attached in this topic!!! Look on my first message.

Vasily
Alex_389
Trusted Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

Works great with SP19
Respect to author
Lakskhmi
New Member.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

Hi,

I am facing the same issue. How can I know whether server is using hotfix.jar or not. I am able to find out three hotfix.jar files in my ovsd folders. 1)Client 2)Event 3)server.
can you please help me?

Thanks,
Lakshmi
Vasily Kamenev
Acclaimed Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

Hi
Your hotfix is empty, the hotfix file attached on the topic answer, download , extract and the you can implement new hotfix file instead existiing.

Vasily
KPatel_1
Frequent Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

will this hotfix work with sp17?
any one tried it?
Vasily Kamenev
Acclaimed Contributor.

Re: HPSD 4.5 and Exchange 2007 Inbound Email - Issue with Attachments

This problem solved in sp28, install it.

Vasily