Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Highlighted
ricardo horta
Regular Collector

HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Server: Windows 2000
Service Desk: 4.5 SP 19
Java: 1.4.2_07
Lately the time of LOGIN in the system has increased greatly.
The some time ago, this time was 19 seconds, now reaches five minutes in some stations.
Does anyone have any hint to improve this time?
Thanks!
www.halogica.com
18 REPLIES
George M. Meneg
Honored Contributor

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Hello Ricardo,

Assuming that there aren't any network issues then the most probable cause for that is that the default views have too many entries.

Try limiting the default views, either using filtering or by using query restrictions or both!
menes fhtagn
ricardo horta
Regular Collector

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Thanks George.
I already noticed the problem related to the VIEWS, in fact, I restricted the result that the VIEWS may return using: Presentation / Search / RestrictedTo.
An additional information, is that when the section falls on timeout, in our case 10 minutes, the reconnection also spends much time.
As to network problems, I informed the fact to the staff of networks that returned that there is no problem.
I am curious to the fact this problem have begun after the upgrade of the server version of Java.
The server used JAVA 1.3 and now uses Java 1.4, we had to update the Java so that it supported the daylight saving of Brazil
www.halogica.com
Mark O'Loughlin
Honored Contributor

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Hi,
run the following on the client systems and check the results that come back to see if an issue can be identified. e.g. Netoewrk or database.

C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\client\bin\sd_client /benchmark
Rajesh Nair
Esteemed Contributor

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

If you have lots of closed calls & you had viewed the view for CLosed calls before shutting the client...then when u login again, the closed view will open first & will take a lot of time depending on the number of calls in the view.

Clear the cache & try to login again.

Also check if you there are any network issues.

Try logging by giving the server ip address instead of hostname.

Regards

Rajesh
Jay Mistry
Frequent Visitor

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Hi Ricardo

I dont agree that you think is a java related problem, we use:-

Server: Windows 2000, Service Desk: 4.5 SP 18 with Java: 1.4.2_07 and we have no such problems.
You may want to check your JAVA_HOME on the application server to make sure this is set correctly.

It is more than likely views that are causing the slowness, do you have calculated fields on default views?

Jay


ricardo horta
Regular Collector

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Thank's to all for participation!
Mark,
I executed the command you requested, the answer is attached.
What do you think about these numbers that appear on the screen?
www.halogica.com
ricardo horta
Regular Collector

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Rajesh,
I marked the option: tools / options / advanced / Purge cache on exit.
Then we checked the directory Documents and Setting / ... / Service Desk / cache, it was empty.
By making new LOGIN, this directory was with 17MB, the largest file is the views.rep.
So did new LOGOUT without checking the option to clear the CACHE and new LOGIN, the time of LOGIN was the same, ie slow, and the directory was with the same length, ie 17MB.
Note: I had already placed the IP address directly on the screen of LOGIN
www.halogica.com
ricardo horta
Regular Collector

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Jay,
Our server application havent the environment variable JAVA_HOME.
What I can verify is that in the WINDOWS register of the
HKEY_LOCAL_MACHINE WINDOWS\SYSTEM\CurrentControlSet\Services\Hp OpenView service desk 4.5 server\Parameters\JVM Library
points to the directory where is this version of Java lives.
I can also look at the LOG SERVICE DESK the following lines:

----------------------------------- -------------------------------------
hp OpenView service desk 4.5 (v4.5.0588.1905 (SP19))
Copyright (c) 2004 Hewlett-Packard Development Company, L.P. All Rights Reserved.
Server settings file: C: \ Program Files \ Hewlett-Packard \ OpenView \ service desk 4.5 \ server \ server_settings.xml
Install folder: C: \ Program Files \ Hewlett-Packard \ OpenView \ service desk 4.5 \ server \
Data folder: C: \ Program Files \ Hewlett-Packard \ OpenView \ service desk 4.5 \ server \
Java runtime name: Java (TM) 2 Runtime Environment, Standard Edition
Java runtime vendor: Sun Microsystems Inc.
Java runtime version: 1.4.2_07 - b05
Java runtime home: C: \ Program Files \ Java \ j2re1.4.2_07
Servername: hiris.halogica.com.br
IP Address: 192.168.1.89
OS name: Windows 2000
OS version: 5.0
OS architecture: x86
Started.
Started.


Which show that the server is using this version of Java.
About calculate the fields that are in default views, I do not know what you are talking about.
Are you suggesting that be the calculation of the number of bytes that each of these fields have?
www.halogica.com
Mark O'Loughlin
Honored Contributor

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Hi,

the performance results are very good so you don't have a general perofrmance issue between the app server and database.

it is looking like the views could be your problem.

Try this. rename the views.dat file and clear the cache again. Then restart the OVSD client. Select a view that does not have any numeric values on it i.e. to deadline or number fields. Close the client then reopen and see if it opens faster.

Calculated fields like To Deadline cause views to slow down on opening and refresh as the values for that field has to be recalculated on every open or refresh thus slowing down the view in loading. Calculated fields are the same (numeric fields)

Also have a look here and see what size the local client log is. Let me know the size please and see if there are any error sin there.

C:\Documents and Settings\-user-profile-name-\Application Data\Hewlett-Packard\OpenView\Service Desk\log
Jay Mistry
Frequent Visitor

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

I agree with Mark, the benchmark results are very good so there is no problem between the app server and the database.
You are connecting to the App server by IP so DNS is not causing the slowness.

As I said before I think views are causing your slowness.
Do as Mark says and rename views.dat then clear the cache down and try running the client again.
calculated fields on views are a known problem when experiencing slowness of the client.

Jay
ricardo horta
Regular Collector

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Again thank you for participating!
I did the following:
- Changed all standard views in a way of containing only two fields (ID or Name / Description)
- Placed a filter in all standard views so that it selected an ID or a name that does not exist
- Renamed the file views.dat
- Cleaned the CACHE
- Executed a LOGOUT and a LOGIN
The time of start-up was of 40 seconds
I will try to put a cable CROSS-OVER between the database and application server, it should take a while ...
Should I comply with the time of 40 seconds of startup and approximately the same time for reconnection occurs when a timeout of the section?
Regardless of the customer's LOG:
He has the size of 96KB and has no error message.
Note: I will wait for the installation of cable CROSS-OVER to score the suggestions, ok?
www.halogica.com
Michel SILVA SO
Occasional Visitor

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Hello Ricardo,

other things to check:

- %SD_SERVERHOME%log\logserver.txt can be to big, so rename it to "logserver.txt.old" and HPOVSD will create a new log file.

- open the Adminsitrator Console>System Panel>General Settings and ensure "Rule manager Debug (more Detailed Entries In Log File)" is UNCHECKED!

- Still in the Administrator Console>Security>Enhanced Auditing>Configuration: right-click and if "Paused" appear click on it. If "Resume" appear leave as is.

So hope those tipps will help you a little bit further.

Rgds,
Michel
Michel SILVA SO
Occasional Visitor

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Another one that I forgot:

- Open Administrator Console>Business Logic>Scheduled Tasks: Verify the amount of scheduled tasks and on the Administration Console Menu open Actions>Reschedule Tasks...

This could help.

The amount of scheduled tasks slow down the server.

Rgds,
Michel
Michel SILVA SO
Occasional Visitor

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

:o)

Today I decided to spam a little bit! :oP

Just kidding

Try this you could be probably be inspired.
;o)

http://geocities.com/helponhpopenview/fastsd.htm

Rgds,
Michel
ricardo horta
Regular Collector

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Hello Michel,
LOG file is small, by the way I renamed it.
The DEBUG of RULES was checked on, I uncheck.
The security options was in RESUME mode.
www.halogica.com
ricardo horta
Regular Collector

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Hello Michel,
This point I really have problems.
I have many tasks scheduled and not have to go without them.
What I know is that there's no way to disable them, so I have to live with them.
www.halogica.com
Mark O'Loughlin
Honored Contributor

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

Hi,

regarding scheduled tasks if they are above a few thousand per app server service you can experience issues.

Rather that live withthem, examine each condition that triggers a scheduled taks and look to see are there other ways to achieve the same thing. In my experience Service Calls may generate the most ammount of SC's as you generally have more service calls than other records.

I generally try to reduce the SC's where possible by making ammendments to the process to reduce the need for the schedule tasks in the first place.

What is the log on time for a cliet from the application server itsself? Is it the same?

Are your users located in one country only - though the benchmark results were good.?
Ashly A K
Honored Contributor

Re: HPOV-SD 4.5 SP 19: Time too long to make LOGIN in the system.

hi!

Have you tried the tips in http://geocities.com/helponhpopenview/fastsd.htm

Have you tried to switch off the firewall in the Client PC ? In the benchmark, i could see that the client is slightly on the higher side. But can't see any reason to worry about.

Also, do a nslookup from the client to server. Again, add the server name and IP in the host file of the client PC.

Try the above links, i hope that will help you.

-Ashly A K
http://geocities.com/helponhpopenview

http://www.geocities.com/helponhpopenview
//Add this to "OnDomLoad" event