Service Desk Practitioners Forum
cancel

HP Openview 5.1 SP6 and Windows 7 - FTP attachment issues

SOLVED
Go to solution
Highlighted
badkarma
Valued Contributor.

HP Openview 5.1 SP6 and Windows 7 - FTP attachment issues

Hi all

 

We are starting to upgrade to Windows 7 and we are starting to get issues when trying to open attachments previously saved to Service Calls and Change records - but only on certain PCs.

 

Symptoms are:

 

HP Openview opens OK

Open a change or service call

Double click on an attachment

Openview hangs for about 20 seconds

A Java error is then returned as:

 

com.hp.ov.obs.impl.util.DeveloperException: Accept timed out
 at com.hp.ov.obs.impl.attachments.ftp.FTP$AttachedItemFTP.getCopy(FTP.java:439)
 at com.hp.ov.obs.impl.idk.rep.AttachedItem.getLocalFile(AttachedItem.java:277)
 at com.hp.ov.ui.ext.core.field.AppAttachmentField.getFileName(Unknown Source)
 at com.hp.ov.ui.ext.core.field.AppAttachmentField.openAttachment(Unknown Source)
 at com.hp.ov.ui.ext.core.field.AppAttachmentField.mouseClicked(Unknown Source)
 at java.awt.AWTEventMulticaster.mouseClicked(Unknown Source)
 at java.awt.Component.processMouseEvent(Unknown Source)
 at javax.swing.JComponent.processMouseEvent(Unknown Source)
 at java.awt.Component.processEvent(Unknown Source)
 at java.awt.Container.processEvent(Unknown Source)
 at java.awt.Component.dispatchEventImpl(Unknown Source)
 at java.awt.Container.dispatchEventImpl(Unknown Source)
 at java.awt.Component.dispatchEvent(Unknown Source)
 at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
 at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
 at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
 at java.awt.Container.dispatchEventImpl(Unknown Source)
 at java.awt.Window.dispatchEventImpl(Unknown Source)
 at java.awt.Component.dispatchEvent(Unknown Source)
 at java.awt.EventQueue.dispatchEvent(Unknown Source)
 at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
 at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
 at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
 at java.awt.EventDispatchThread.run(Unknown Source)

 

User can use another PC and access attachements OK.

 

HP Openview completely uninstalled and reinstalled in Win7.

 

Have noticed that no HKLM\Software\Hewlett-Pac kard\HP Openview registry entries can be seen using REGEDIT but on XP machines, reg entries exist.

 

Have also installed as Administrator and "Run as" administrator for the HP Console app. Still no joy.

Also gave "Everyone" full permissions to C:\program files (x86)\HP Openview - still no joy.

 

Would be grateful if someone knows the answer to this, many thanks.

 

I have searched the forum for HP 5.1 plus Windows 7 but cannot see anything (only 4.5 Service Desk)

 

Thanks!

 

 

2 REPLIES
DrFoul
Honored Contributor.
Solution

Re: HP Openview 5.1 SP6 and Windows 7 - FTP attachment issues

Hi "Badkarma"

Don't worry, this issue has nothing to do with your nickname. :)

 

I think the timed out is caused by a firewall. Probably the one in Windows 7 itself.

 

Please launch ovconsole and login as system, then navigate to System Settings > Attachment Settings.

The host field should have an IP address of hostname known in your DNS, and the users should not have this hostname in an lmhosts or hosts file themselves. :)

 

 

You say 5.1 sp6, so when you run ovsdversion (HP OpenView\bin folder), then it would give a build version 5.10.190, right?

 

Please note that Windows 7 is only supported since patch 16 (5.10.334):

http://support.openview.hp.com/selfsolve/document/FID/DOCUMENTUM_QXCR1001094578

 

I've attached the release notes from patch 17 (latest) for your convenience.

 

Since there are other users who can use the client and open attachments without problems, I guess that SD 5.10.190 works on Windows 7 too. You may run into other problems fixed in patches 7 - 17, though.

HPE Software Support

If you find that this or any post resolves your issue, please mark it as an accepted solution. Kudos are welcome.
badkarma
Valued Contributor.

Re: HP Openview 5.1 SP6 and Windows 7 - FTP attachment issues

Thank you very much!

 

Changing our servername from WWLOPENVIEW in the attachment settings host name to its IP address worked a treat!

We must have some kind of internal DNS issue on part of our subnets which we will check, but by doing this our Win 7 users can now open attachments! It maybe because our Win7 users are on a different subnet to our XP users.

 

Will look into the update to SP17 shortly once I have found the downloads area for it :) - my challenge for today :)

 

Thanks again for the reply and fix. I will push the relevant solved button.