Service Desk Practitioners Forum
cancel

Format date custom field

Highlighted
Johbo
Respected Contributor.

Format date custom field

Hello, we have a custom field that is filled bij a UI rule with the function Add Current data plus one day.

Now we have upgraded from HPSD4.0 to HPSD4.5 and the format of the date is changed. The format of the custom date field is MMM/d/yyyy (dec/28/2005).

This should be 12/12/2005.

We have changed the display format where you create the custom field in short date medium time but that does not work. The custom field is created as a date field.

Any ideas??


5 REPLIES
Robert S. Falko
Acclaimed Contributor.

Re: Format date custom field

John,

You probably want to set the display format of the custom field to Short Date.

However, you may also need to define what is meant by "Short Date", and which date format to use in forms.

In Application Account -> Date format -> Short Date Style set the value to dd/MM/yyyy (or MM/dd/yyyy - it is not clear from your example which you need).

Set the Date format to Short Date.

This "feature" allows you define the appearance of dates differently for each account (and obliges you to set it for each account). You'll probably want to creates some templates to handle this requirement for new accounts. Use Data Exchange to update existing accounts, if required.

-Josh
Johbo
Respected Contributor.

Re: Format date custom field

Josh, Thank for your reply.

I have set the short date in all the application accounts to M/d/yy. This is working fine in al other date fields. Even after i changed the display format for the custom field to short dat medium time it did not show the right format. The date in custom field is still Dec/29/2005.

Could the format of the system time of the database server be of influence??? Because the rule that filled the custom field is using the Add Current Date function.

John
Robert S. Falko
Acclaimed Contributor.

Re: Format date custom field

John,

I have not seen this behavior before, so I can only suggest some diagnostic questions:

1. Does the problem still exist if the rule is disabled?

2. Is it a UI rule or a DB rule?

3. Are you logging out and in between configuration changes?

4. Is the problem limited to one PC?

5. Can the problem be reproduced in other fields?

I doubt that the problem concerns the system date format, but who knows?

-Josh
Johbo
Respected Contributor.

Re: Format date custom field

Josh,

1 the field is only filled with the UI rule. So if i diable it the problem is solved but we do ot hget any info in the field anymore :-)

2 Its a UI rule

3 Yes we log in and out but we do not empty the cache, that could be it.

4 everybody has the problem. Tools -Options has no influence

5 no because in the other fields tools - options works

6 system date is on the format we need so that is not the problem indeed.

during this reply i emptied the cache and now it works. We also had a crash with hpsd so we had to restart the service, that might have helped also. Cannot exactly explain but thanks a lot for your help.
Johbo
Respected Contributor.

Re: Format date custom field

see above