Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Flashing tray icon causing Rule Manager to hang

Highlighted
Leiv Arild Ande
Occasional Contributor

Flashing tray icon causing Rule Manager to hang

Hi,
we are currently using Service Desk (SD) 4.5 SP15.
We recently experienced that the rule execution encountered a hang situation. The application server still responded (e.g. when opening service calls), but DB rules were not executed as events occured (they went into the task queue and stayed there for about 10 minutes).

Our examination of the issue indicated that this delay has something to do with user profiles where the "Flashing tray icon" option is set, and no open sessions exist for the corresponding user(s).

Has anyone experienced anything like this?
It sure impairs the throughput of the system, because the rule manager execution seems to halt until some timeout value has been reached.
2 REPLIES
Jan Pavelka
Occasional Visitor

Re: Flashing tray icon causing Rule Manager to hang

Hi Leiv,

we had faced the same behaviour of SD but we didn't discovered the connection with flashing tray icon.

We thought it is caused by a bad rule manager which wasn't able to invoke external utilities (known issue).

Recently we upgraded to SP19 and it works fine (fortunately).

BR
Jan
Leiv Arild Ande
Occasional Contributor

Re: Flashing tray icon causing Rule Manager to hang

Hi Jan,
sorry I haven't been very active at this forum for a while.

We're soon upgrading from SP15 to SP20, and haven't experienced this issue again since I entered this thread. :)

So I kind of hope this was a one time experience. But thank you anyway!
//Add this to "OnDomLoad" event