Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Errors in OVSD 4.5

SOLVED
Go to solution
Highlighted
Michelle Thomas
Acclaimed Contributor

Errors in OVSD 4.5

Hello, I have three computers that once they login to OVSD they receive the following errors: java.lang.NoSuchMethodError: com/hp/ifc/util/AppWeakReferences: method (JJ)V not found

I have already done the following:
Cleared cache
Deleted Java from Registry and HD and reinstall (both OVSD and Java)
Reinstall San Java 6.1

I still receive the same errors. Help me please.

Thanks,
Michelle
9 REPLIES
Craig R Taylor
Collector
Solution

Re: Errors in OVSD 4.5

With HPSD 4.5 you need to use the Microsoft JVM. Have you installed it?
You can observe a lot just by watching. - YOGI BERRA
Michelle Thomas
Acclaimed Contributor

Re: Errors in OVSD 4.5

No I do not have JVM installed on these machines, but that is because when I attempted to install JVM from Microsoft I was prompted that it is no longer supported and I must install Sun Java.
Craig R Taylor
Collector

Re: Errors in OVSD 4.5

Yeah its unsupported but thats what is required for HPSD. Sad but true :(
You can observe a lot just by watching. - YOGI BERRA
Michelle Thomas
Acclaimed Contributor

Re: Errors in OVSD 4.5

Okay i did some digging and I found an install for MS JVM. Removed OVSD, installed JVM, and the reinstalled OVSD, same error. Do I have to remove Sun Java first?

Thank you for all your help.
JaS_4
Honored Contributor

Re: Errors in OVSD 4.5

MSJVM and Sun Java can coexists. The client will just use the MSJVM. Sun java is only used on the server.
Choon Hian
Acclaimed Contributor

Re: Errors in OVSD 4.5

I have the same error, does anyone have a resolution?
Choon Hian
Acclaimed Contributor

Re: Errors in OVSD 4.5

I have the same errors, is there a resolution found?
Carl Klein
Acclaimed Contributor

Re: Errors in OVSD 4.5

It looks like an old version of the mentioned class (AppWeakReferences) is used. I assume you have upgraded to the right SP level but could it be that there is still an old hotfix.jar in the client/lib directory or in the user profile directory (if you use Remote Updater)? If that is the case removing that should solve the issue.
Ashly A K
Honored Contributor

Re: Errors in OVSD 4.5

hi!

Looks like the PC don;t have a valid Virtual Machine.

use the CD ROM of SD 4.5 and install the components one by one, from the top of the Installation menu for Client.

Also, you can try the below site
http://www.geocities.com/helponhpopenview

Ashly A K
http://www.geocities.com/helponhpopenview
//Add this to "OnDomLoad" event