Service Desk Practitioners Forum
cancel

Email message to this user

SOLVED
Go to solution
Highlighted
Damian Comer
Regular Contributor.

Email message to this user


Afternoon all

We use Lotus Notes and when we use this function in OV it opens a blank message in Lotus, but also opens a webpage .
The former is what we want the latter isn't.

I tried investigating adding Lotus in the Options, Applications tab but I realise this won't do what I need.

Any ideas?
4 REPLIES
Gyula Matics_1
Acclaimed Contributor.
Solution

Re: Email message to this user

You need to modify the smart action that opens the email sending window.

By default it is set to open internet exporer with a mailto: url. That's why you get the empty web page.

I've never used Lotus, so I don't know how to configure it. Generally, you'll have to find out how to call Lotus from the command line to cause it to open a new message. Then configure this as a smart action, replacing the default one.
Gyula Matics_1
Acclaimed Contributor.

Re: Email message to this user

This probably works with Lotus as well, since it just calls the mailto: url handler directly.

I don't know whose solution is this, I've probably saved it off these forums...

"If you don't want the annoying starting of for instance internet explorer, you can use rundll to start your action.
Define rundll32 as application

Action will be:
application rundll32

parameters:

url.dll,FileProtocolHandler mailto:[Caller;E-mail]?subject=Service%20Call:%20[ID]%20/%20[Omschrijving]&body=[Information] has been closed by [Assignment;To person].
"
Mihai Tita
Outstanding Contributor.

Re: Email message to this user

Hi,

IE isn't your default e-mail application.
You need to create a new application, for example:
Name: Lotus Notes
Command Line : C:\Program Files\Lotus\Notes\notes.exe
Start in : C:\Program Files \Lotus\Notes\
Description : Startup Lotus Notes
After that you need to change the smart action to open the application just created, because it is set to open IE application (by default).

Mihai
Damian Comer
Regular Contributor.

Re: Email message to this user

Cheers all

After I got the first notification from Gyula Matics I revisited the settings.

You pointed me in the right direction Gyula so thank you.

All I did was take out the application setting which was set to Internet Explorer and replaced it with Lotus Notes.

Athough this doesn't itself open a mail message it takes out the default Application.

Mahai T I think this is what you have written, so thanks to you also.