Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

E-mail Inbound

SOLVED
Go to solution
Highlighted
BUDI RAHARDJO_2
Regular Collector

E-mail Inbound

I've configured email inbound (by activating the SMTP protocol and setting the IP Port). I've also setup the E-mail properties accordingly, e.g. define the "Inbound E-mail addresses", etc.

However, when I tried to send email to service desk (e.g. servicedesk@test.com) nothing happens, no ticket is created, nothing in logserver.txt, and no replies from SD.

Any help is appreciated,
Thanks.
35 REPLIES
Mark O'Loughlin
Honored Contributor

Re: E-mail Inbound

Hi,

please attach a screen shot of your e-mail settings from the Admin Consloe for the General & Inbound E-mail settings.
Remote Manageme
Acclaimed Contributor

Re: E-mail Inbound

Hi,

Try to send the mail to userID that you had created for the server in inbound email section as 'userID@IPADDRESS'.

Check whether it reaches.

Regards,

Saurabh
Saurabh Dubey
Honored Contributor

Re: E-mail Inbound

Hi,

Try to send the mail to userID that you had created for the server in inbound email section as 'userID@IPADDRESS'.

Check whether it reaches.

Regards,

Saurabh
Modesty is good!! But remember, all your life other people will try and take your achievements away from you, don't make it easy for them.
BUDI RAHARDJO_2
Regular Collector

Re: E-mail Inbound

Not sure what you mean by @IPADDRESS, can you give me an example?

Thanks.
Saurabh Dubey
Honored Contributor

Re: E-mail Inbound

Hi,

If the IP address of SD server is 172.16.85.35, create an inbound email ID as servicedesk (in Admin Console -> General Settings -> Email -> Inbound Email Addresses).

And then send a mail to

servicedesk@172.16.85.35

Hope this helps...

Regards,

Saurabh
Modesty is good!! But remember, all your life other people will try and take your achievements away from you, don't make it easy for them.
BUDI RAHARDJO_2
Regular Collector

Re: E-mail Inbound

Hi Mark,

What is your email address? I want to send the screenshots. I prefer not to show the inbound email address on this forum to avoid unwanted SD tickets being created :-).

Ashly A K
Honored Contributor

Re: E-mail Inbound

hi!

Pls visit http://www.geocities.com/helponhpopenview

You can find the deatils doeucmnet about how to configure and how to trouble shoot.

-Ashly
http://www.geocities.com/helponhpopenview
BUDI RAHARDJO_2
Regular Collector

Re: E-mail Inbound

I tried using the IP Addres but didn't work. Do I need to create an email account for Servicedesk first?

We have an email gateway in our network, if I only use the SD server IP address, how does email from outside our network knows where to send email to?
Saurabh Dubey
Honored Contributor

Re: E-mail Inbound

Hi,

The SD server IP address needs to accept incoming mails hence the port on the firewall needs to be opened.

Hope this helps...

Regards,

Saurabh
Modesty is good!! But remember, all your life other people will try and take your achievements away from you, don't make it easy for them.
BUDI RAHARDJO_2
Regular Collector

Re: E-mail Inbound

Hi Ashly,

I was able to telnet using this command;
telnet server.domain.name 25

I followed steps in your document, but when I tested inbound email (sending email to servicedesk@server.domain.name), I got email delivery failure notice.

Rgds,
Budi.
Ashly A K
Honored Contributor

Re: E-mail Inbound

Hi,

Have you send mail from the telnet itself ?
Is the SMTP of Windows turned off in the SD Server ?
-Ashly
http://www.geocities.com/helponhpopenview
BUDI RAHARDJO_2
Regular Collector

Re: E-mail Inbound

Hi Ashly,

How do I test sending email from telnet? I've enabled SMTP in SD App Server configuration settings.

I've also configured IP Port to 25 and SMTP Identifier to default.

Thanks.
Mark O'Loughlin
Honored Contributor

Re: E-mail Inbound

Hi,

Send the screenshots here and i wil take a look for you.

oloughlin.mark@gmail.com
Ashly A K
Honored Contributor

Re: E-mail Inbound

hi!

SMTP should be disabled. HP uses its own SMTP Engine. If both are running(HP and Microsoft) it may cause probelm. Could you publish the screen shots and server log file ?

-Ashly
http://www.geocities.com/helponhpopenview
BUDI RAHARDJO_2
Regular Collector

Re: E-mail Inbound

Hi Ashly,

I enabled SMTP in SD server configuration (see attachment).

Here's logserver.txt:

Mon, 10/04/2006 07:00:33 hp OpenView service desk 4.5 (v4.5.0588.1104 (SP11))
Mon, 10/04/2006 07:00:33 Copyright (c) 2004 Hewlett-Packard Development Company, L.P. All Rights Reserved.
Mon, 10/04/2006 07:00:33 Server settings file: D:\apps\Hewlett-Packard\OpenView\Service Desk 4.5\Server\server_settings.xml
Mon, 10/04/2006 07:00:33 Install folder : D:\apps\Hewlett-Packard\OpenView\Service Desk 4.5\Server\
Mon, 10/04/2006 07:00:33 Data folder : D:\apps\Hewlett-Packard\OpenView\Service Desk 4.5\Server\
Mon, 10/04/2006 07:00:33 Java runtime name : Java(TM) 2 Runtime Environment, Standard Edition
Mon, 10/04/2006 07:00:33 Java runtime vendor : Sun Microsystems Inc.
Mon, 10/04/2006 07:00:33 Java runtime version: 1.3.1_03-b03
Mon, 10/04/2006 07:00:33 Java runtime home : d:\apps\JavaSoft\JRE\1.3.1_03
Mon, 10/04/2006 07:00:34 Servername : (blanked)
Mon, 10/04/2006 07:00:34 IP Address : (blanked)
Mon, 10/04/2006 07:00:34 OS name : Windows 2000
Mon, 10/04/2006 07:00:34 OS version : 5.0
Mon, 10/04/2006 07:00:34 OS architecture : x86
Mon, 10/04/2006 07:00:34 Started.
Mon, 10/04/2006 07:00:34 Started.
Mon, 10/04/2006 07:00:34 Started.
Mon, 10/04/2006 07:00:34 Starting agent manager on (blanked)
Mon, 10/04/2006 07:00:34 Job queue monitor starting.
Mon, 10/04/2006 07:00:34
Saurabh Dubey
Honored Contributor

Re: E-mail Inbound

Hi BR,

Small correction: I saw the snapshot of the SMTP enable in config settings. You have allowed access to *.*.*.* and denied access to *.*.*.*. You need to remove the deny access.

Hope this helps...

Regards,

Saurabh
Modesty is good!! But remember, all your life other people will try and take your achievements away from you, don't make it easy for them.
Saurabh Dubey
Honored Contributor
Solution

Re: E-mail Inbound

Hi BR,

Just a brand new clean start effort to help you.

1. Go to Server Settings Editor, and Enable SMTP. Allow = *.*.*.*, deny empty.

2. Stop the SMTP of the Windows Server IIS.

3. Go to Admin Console -> General Settings -> Email -> Inbound Email Templates. Add a new entry here : servicedesk, map it to a template of your choice.

4. Enable the Service Desk Server's IP address on all your firewalls in the path for incoming mails.

5. Send a Mail to servicedesk@IPaddress (e.g. servicedesk@172.16.85.35), with the subject line as New and message in the body of the mail.

Follow these steps and then see if you still face the same problems.

Hope this helps....

Regards,

Saurabh
Modesty is good!! But remember, all your life other people will try and take your achievements away from you, don't make it easy for them.
Ruth Porter
Honored Contributor

Re: E-mail Inbound

Hi there,

For inbound email, your email system must forward any email for the SD inbound address to the SD application server on the port you choose. You may also need to configure firewalls as a previous response has said.

If you have done this and switched email debug on, you should see messages in logserver.txt

Hope this helps

Ruth

PS it might be nice if gave some points to the people who have responded to you.
http://www.teamultra.net
Ashly A K
Honored Contributor

Re: E-mail Inbound

hi!

is it resolved ?

-Ashly
http://www.geocities.com/helponhpopenview
BUDI RAHARDJO_2
Regular Collector

Re: E-mail Inbound

It's not resolved yet. Unfortunately I'm not familiar with firewall. I was trying to send email from my hotmail account, but I didn't get any reply from SD.

I may need to try sending email from company's email.
Mark O'Loughlin
Honored Contributor

Re: E-mail Inbound

Hi Budi,

If you can provide the screenshots we should be able to get things going for you. if you can't provide screenshots, you could type the setings and their current values and mayme we can work from there (if its pratical)
Neil_Walker
Super Collector

Re: E-mail Inbound

Hi Budi

I had the same problem when implementing SD on our site and it was all down to our mail gateway (we use exchange) not knowing where to route the mail. I had to create a smart host to redirect any mail for the SD smtp address to the SD server.

To test to see if you can connect direct, there's an app called postie (http://www.infradig.com/) which allows you to send mail form the command line via any server. Try this and send the mail direct to your SD server and see if that works. If this works then it's routing on your mail system.

Neil
BUDI RAHARDJO_2
Regular Collector

Re: E-mail Inbound

I keep getting "failed E-mail delivery notification" immediately after sending email to SD. It seems that I've configured SD server wrongly somewhere.
BUDI RAHARDJO_2
Regular Collector

Re: E-mail Inbound

Hi Mark,

I've sent you the screenshots.
Thanks for taking a look..
//Add this to "OnDomLoad" event