Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Display Parent BR/RFC giving error

Highlighted
Kim Holden
Super Collector

Display Parent BR/RFC giving error

Good Afternoon everyone

I have just discovered that the Smart Action "Display Parent BR/RFC" displays an error of "an unknown operator was used in the CLI" when used on an RFC etc that doesn't have a Parent RFC or BR.

I am using Openview version 4.5 service pack 21.

All of the other actions show a list box with no entrys if there are no records that match the criteria - and this one should do the same.

The coding in the smart action area looks fine compared to the rest:

"Change Driver Form" "ID=[Parent BR or RFC]" -listalways

Can anyone point me in the right direction as to how to fix this error?

Thanks for your help in advance :)

Kim Holden
3 REPLIES
Ruth Porter
Honored Contributor

Re: Display Parent BR/RFC giving error

Hi Kim,

This seems to a "feature" of using sd_datform with "ID=".

Presumably "Parent BR or RFC" is a custom field - if it is text or number, you could preset it to zero (in the template) and then I think the error will go.

Hope this helps, Ruth
http://www.teamultra.net
Kim Holden
Super Collector

Re: Display Parent BR/RFC giving error

Thanks Ruth :)

I checked, it is a Number field - but unfortunately the minimimum number is already set to 0 :)

Any other ideas? :)

Kim
Ruth Porter
Honored Contributor

Re: Display Parent BR/RFC giving error

Hi Kim,

I did not mean the minumum but rather in all your templates preset it to zero.

Regards, Ruth
http://www.teamultra.net
//Add this to "OnDomLoad" event