Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Deployment of multiple SD 5.1 clients - SD5.10.028 and SD5.10.090

Highlighted
Steve-Davis
Occasional Advisor

Deployment of multiple SD 5.1 clients - SD5.10.028 and SD5.10.090

Does anyone know how to deploy both SD5.10.028 and SD5.10.090 clients to the same desktop? Our current development system is SD5.10.090, and our production system is SD5.10.028. We have discovered that an 028 client cannot connect to an 090 server, and vice versa (but I hope we are wrong). I need to connect to both server versions from my desktop.
3 REPLIES
jconsola20
Occasional Visitor

Re: Deployment of multiple SD 5.1 clients - SD5.10.028 and SD5.10.090

I don't know that you can. I am on SD 4.5 sp18. I recently upgraded our Dev server to sp22 for testing purposes and was not able to acces the dev server from my sp18 client. I had to remote desktop to the Dev server and use the local client. After my testing, I ended up "downgrading" back to sp18 so others could access the Dev server again.
AndrewB
Regular Collector

Re: Deployment of multiple SD 5.1 clients - SD5.10.028 and SD5.10.090

I am having a similar issue in trying to set up testing for SP2. The only thing I can think of is application virtualization (besides extra boxes).

Good luck!
Steve-Davis
Occasional Advisor

Re: Deployment of multiple SD 5.1 clients - SD5.10.028 and SD5.10.090

Here is info from HP Support:

"Multiple Service Desk Console installations on the same box is not a type of installation we support. You may want to consider the Web Start solution instead of multiple console installations. Via Web Start, you should be able to access different management servers on different patch levels without conflicts. For information on how to install a GUI Client using Java Web Start, refer to the Service Desk Installation Guide."

So, I think the best I can do for now is to use 028 desktop client to connect to my production system and the 090 web console to connect to my developement system (or remote connect in when needed).

I wish vendors (in general) maintained backwards compatibility for patch level releases. Newer clients should still be able to connect to older servers.
//Add this to "OnDomLoad" event