Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Database rules not running at all.

Highlighted
Meine de Vries
Regular Collector

Database rules not running at all.

At times we are experiencing a problem with database rules not running.

We have several rules that always run after a new ticket is created to set some variables to their initial values, and we also have rules to inform the caller that their ticket was opened, etc.

However after creating a service call not a single database rule was executed.

Later when we modify the ticket and save it again other database rules do execute.

We are running SD45 (SP22).

Right now when we encounter this we restart the application on the server and everything seems to be working fine again.

Also, we are running the SD application on two separate servers and the problems appears to occur on only one of them.

This is very little information, but it's all we got.

Has enyone ever experienced something like this?

Thanks, Meine
4 REPLIES
Mark O'Loughlin
Honored Contributor

Re: Database rules not running at all.

Hi,

first off check your scheduled tasks. Are they high i.e. in the 1000's?

Are you running the OVSD as a service with extended memory allocation for the Java?
Meine de Vries
Regular Collector

Re: Database rules not running at all.

We have about 400 scheduled transactions per server for a total of 800.

I am not sure if we run with extended memory allocation the Java. How could one tell?

Thanks, Meine
Venkatesha_1
Esteemed Contributor

Re: Database rules not running at all.

Hi,

How are you starting the SD application server ?.



Meine de Vries
Regular Collector

Re: Database rules not running at all.

The SD applications run on windows machines and we start them using:

Start-->Services

Select: HP OV SD45

Start the Service

Meine
//Add this to "OnDomLoad" event