Service Desk Practitioners Forum
cancel

Data exchange Error SD4.5 SP17

Highlighted
De Naeyer Robby
Trusted Contributor.

Data exchange Error SD4.5 SP17

When trying to start a data exchange task (import) I get the following error:
Parser error: java.lang.ArrayIndexOutOfBoundsException
at com/hp/ifc/ext/AppSingleLoad.processEntity
at com/hp/ifc/ext/imp/AppEntityHandler.endElement
at com/jclark/xml/sax/Driver.endElement
at com/jclark/xml/parse/EntityParser.parseContent
at com/jclark/xml/parse/EntityParser.parseDocumentEntity
at com/jclark/xml/parse/DocumentParser.parse
at com/jclark/xml/parse/base/ParserImpl.parseDocument
at com/jclark/xml/sax/Driver.parse
at com/hp/ifc/ext/imp/AppImpTaskParser.parseFile
at com/hp/ifc/ext/imp/AppImpTaskParser.objectToSD
at com/hp/ifc/ext/imp/AppImpTaskParser.parseChunk
at com/hp/ifc/ext/imp/AppImpTaskParser.parseSerial
at com/hp/ifc/ext/imp/AppImpTaskParser.parse
at com/hp/ifc/ext/imp/ImportXmlCim.startImportTask
at com/hp/ifc/ext/imp/ImportXmlCim.startImportTask
at com/hp/ifc/ext/imp/ImportXmlCim.main
java.lang.ArrayIndexOutOfBoundsException
fatal_error occurred while processing ovowindowsservices.xml_1.xml

What i have done so far:
========================
- Reinstalled HP OV SD (on server and client)
- Tried importing other xml files (Same error)
- Search the internet (Not many results on this error.)
- What could be usefull! Since i reinstalled on the aplication server the client can't be upgraded. When i try the upgrade to SP17 it stays on SP0.


Environment:
============
Version: Service Desk 4.5 SP17
Database: Oracle
Operating system server: Windows 2000 SP4
Operating system client: Windows XP
Java Version:1.3.1_03

Any help would be usefull.
3 REPLIES
De Naeyer Robby
Trusted Contributor.

Re: Data exchange Error SD4.5 SP17

Just to avoid confusion. I'm doing the import from a local client and i did not use the client on the server. (that wont upgrade).
George M. Meneg
Acclaimed Contributor.

Re: Data exchange Error SD4.5 SP17

Hello,

Please make sure that a blanc line follows the the at the end of the xml file.

menes fhtagn
De Naeyer Robby
Trusted Contributor.

Re: Data exchange Error SD4.5 SP17

Thanks for your feed-back,

But there are even 3 blanc lines at the end of the document.

It has to be somthing else.