Service Desk Practitioners Forum
cancel

Data Exchange - updating read only fields

SOLVED
Go to solution
Highlighted
Blimp
Valued Contributor.

Data Exchange - updating read only fields

SD4.5 SP30 - Hello

I am trying to do a mass import of new CIs into our CMDB from excel, but cannot workout how I go about updating three of the fields that use 'Organization' names and so are read only in the CI form. I have successfully imported all the other fields but get 'read only' error messages for the three fields that use Organization.

Is it even possible to update a field that uses another table for it's source?

I am presuming I need to create another class but I can't get my head around how I link this with the CI form and the Organization table data.

Any help gratefully appreciated.
5 REPLIES
The Pike
Acclaimed Contributor.
Solution

Re: Data Exchange - updating read only fields

Let's focus on the read-only error first. Post a screenie or log showing the error.

You might want to check if the account being used to run the data exchange task has access to the fields. Also, look if fields are not enabled for the current category they're in.

Points are welcome.

The Pike
Blimp
Valued Contributor.

Re: Data Exchange - updating read only fields

I get the following message for three fields that all use an Organization name:

Program error: the attribute ' owner organization.' of this configuration item cannot be modified, because the configuration item item was opened in view mode or because the attribute is read-only.
while processing attribute CI_OWNER

As a trial I gave the import account Sys Admin rights and it imported the data correctly - so I guess there may be arole/permission issue somewhere.

The Pike
Acclaimed Contributor.

Re: Data Exchange - updating read only fields

Indeed. If the suggestion was helpful or correct, please assign points accordingly.

The Pike
Blimp
Valued Contributor.

Re: Data Exchange - updating read only fields

Thanks for your help
Blimp
Valued Contributor.

Re: Data Exchange - updating read only fields

Thanks again. Gave admin rights to the importing account and it worked okay.