Service Desk Practitioners Forum
cancel

Data Exchange and Batch Files

Highlighted
Leon B_1
Super Contributor.

Data Exchange and Batch Files

Hi All

I have a strange case where a batch file I am using to perform my data exchange tasks does not seem to be working correctly. What is happening is that SD_Export is creating an XML that contains the correct date and time values, but then SD_Import is importing the data without the time values. What I find strange though;

- The task is fine when run in the HPSD client
- The task runs fine when the batch file is run manually
- The task only performs the error described in the first paragraph when scheduled

My environment is a Win2k3 Server running SD4.5 with SP9 connected to a SQL server.

Thanks in advance,
Leon
4 REPLIES
Michael Lutfi
Outstanding Contributor.

Re: Data Exchange and Batch Files

If you are using windows scheduled tasks what rights do you have for the scheduled task to run as...
Leon B_1
Super Contributor.

Re: Data Exchange and Batch Files

The user that it's currently running under is a local administrator of the server.

I don't think the security should be a problem, as the task appears to run successfully...
Michael Lutfi
Outstanding Contributor.

Re: Data Exchange and Batch Files

Ok may I please have an idea of the Import Mapping because I have a strong feeling I know the reason...if your XML is being generated correctly then there could be something wrong with your Import Mapping...so please just post a few screen shots showing the import mapping...
Leon B_1
Super Contributor.

Re: Data Exchange and Batch Files

Further to my problem...

I copied the XML files from Prod to Test and ran the data exchange there.

Everything seems to have imported correctly.

This is precisely what's going on;

- SD_Export generating XML
- XML contains SLAs with a start date and a start time of 0:00
- When importing;
-- Dev will import the SLAs correctly
-- Prod will import the SLAs with +11GMT (my timezone)

Michael do you still want to see the Import Mappings? They are both the same in Dev and Prod....