The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

DB Rules not always sending outbound email

Highlighted
Thorfinn Thomas
Regular Collector

DB Rules not always sending outbound email

Hi,

We have some DB Rules that is supposed to send out emails; sending email to caller when a servicecall is created and not closed on first call is one of them, others send SLA violation notifications to servcedesk manager.

For some reason the SLA notifications have stopped working, while the emails to caller is sometimes being sent, and otherr times not.

I know that some of these rules are still firing, but just not sending the email (they do other things as well).

I can't find any trace of a reason why these emails are not send.

We're using HPOVSD 5.0.

regards,
Thorfinn Thomassen
5 REPLIES
Ruth Porter
Honored Contributor

Re: DB Rules not always sending outbound email

Hi Thorfinn,

Have you set email debug and what doe sthe log say?

Regards

Ruth
http://www.teamultra.net
Thorfinn Thomas
Regular Collector

Re: DB Rules not always sending outbound email

Hi Ruth,

thanks for your rapid response.
Do you mean DB Rule debug? If so the answer is yes, but I find nothing there.

regards,
Thorfinn
Thorfinn Thomas
Regular Collector

Re: DB Rules not always sending outbound email

Hi again,

disregard my previous messgae - the answer is "No", we haven't set email debug.
This has been overlooked, relying only on DB Rule debug. I will do so now, and then we'll see.

Thanks again!

regards,
Thorfinn
Thorfinn Thomas
Regular Collector

Re: DB Rules not always sending outbound email

Hi again,

I found that all external email messages was failing on smtp relay, the exchange administrator must have made some changes.

When looking more closely, internal messages are still being received by end users, so I believe we've found the core of the problem.

Thanks for the help.

regards,
Thorfinn
Thorfinn Thomas
Regular Collector

Re: DB Rules not always sending outbound email

The solution was found in the system logs. External email was no longer being relayed.
//Add this to "OnDomLoad" event