Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Creating a custom code - SD4.5 Patch 15

Highlighted
NSC
Super Collector

Creating a custom code - SD4.5 Patch 15

Hi all

I am trying to create a custom code. I went into custom fields, and created a code, and activated it. Then i went into the codes section and went to that new code, and right clicked to create a new attribute. i typed the name, and when i clicked save and close i get the following error:

JDBC error 942: ORA-00942: table or view does not exist, SQL state: 42000 for query: insert into ifc_versions(vrs_cat_oid,vis_version) values (6333187754341712,1)

i checked the database and this table does not exist. I recently setup the same sd4.5 + patch 15 on a test server, and this table does not get installed.

Any ideas how i can get around this? i really need to create these custom codes!!!

Thanks!
4 REPLIES
George M. Meneg
Honored Contributor

Re: Creating a custom code - SD4.5 Patch 15

Hello NSC,

When using a custom code field for the first time (till SP19 you cannot create a custom code, merely you can activate a spare one) some times the client needs restart before the code can be populated. Restart the client and see what happens.
menes fhtagn
NSC
Super Collector

Re: Creating a custom code - SD4.5 Patch 15

Hi George

Thanks for the quick reply!!

I was initially having problems seing my custom code - so i restarted the server. This allowed me to see the custom code. I have restarted my client a number of times too... still i cannot enter in an attribute.

I guess i will have to run the patch 19 upgrade on a test system before production.

Thanks!!
Mark O'Loughlin
Honored Contributor

Re: Creating a custom code - SD4.5 Patch 15

Hi,

what SP are you currently on? Do you know thatthere is no migration to OVSD 5.x from SP 18 and above?

Can you deactivate the code and try another one and see if you can enter some atributes - as a test?
George M. Meneg
Honored Contributor

Re: Creating a custom code - SD4.5 Patch 15

Hello NSC,

There must be a missunderstanding. You cannot create a custom code field neither on SP19. What I wrote is that for all service packs, up to SP19 you cannot create a custom code, merely you can activate a "custom code field" that exists but it is not activated.

Clear the cache of the server and restart it. If the problem is not solved, try to use some other custom code. If this happens again, i think that you should call HP.

In other post is said that from SP20, it would be possible to actually create new custom code fields.
menes fhtagn
//Add this to "OnDomLoad" event