Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Connection to service desk repository failed

Highlighted
Justin Trant
Regular Collector

Connection to service desk repository failed

Hi,

We have been seeing the following activity in the server logs of one of our app servers:

[I]Fri, 15/06/2007 16:24:34 Connection to service desk repository
Fri, 15/06/2007 16:24:35 Connection to service desk data
Fri, 15/06/2007 16:24:35 Connection to service desk repository
Fri, 15/06/2007 16:24:36 Connection to service desk data
Fri, 15/06/2007 16:24:36 Connection to service desk repository
Fri, 15/06/2007 16:24:37 Connection to service desk data
Fri, 15/06/2007 16:24:37 Connection to service desk repository
Fri, 15/06/2007 16:24:38 Connection to service desk data
Fri, 15/06/2007 16:24:38 Connection to service desk repository
Fri, 15/06/2007 16:24:38 Connection to service desk repository failed
Fri, 15/06/2007 16:25:33 Connection to service desk repository
Fri, 15/06/2007 16:25:34 Connection to service desk repository
Fri, 15/06/2007 16:25:35 Connection to service desk repository
Fri, 15/06/2007 16:25:36 Connection to service desk repository
Fri, 15/06/2007 16:25:37 Connection to service desk repository
Fri, 15/06/2007 16:25:37 Connection to service desk repository failed[/I]

When this occurs, users of the Service Desk application receive a "Connection to Service Desk repository failed" error, the application freezes for a moment and they can then continue as normal (probably the client connecting to another available app server).

Restarting the app server service under Windows Services restores connectivity for clients. Testing the DB connection in the Server Settings Editor reports no errors.

Each time this happens, the server logs stop reporting the amount of scheduled tasks. Am I missing something, or is there a difference between the repository and the actual DB itself?

Does anyone have any ideas as to what is causing this? Any help appreciated.

Thanks,
Justin.
2 REPLIES
Mark O'Loughlin
Honored Contributor

Re: Connection to service desk repository failed

Hi,

do the log files for any other SD application server show the same error?

Basically is the DB going down or becoming inaccessible or is this one SD application server unable to contact the DB (say because of an intermittent switch problem)
Justin Trant
Regular Collector

Re: Connection to service desk repository failed

Hi Mark,

Thanks for your reply.

The other application servers show similar errors (to a lesser extent), but the two server instances on this particular box seem to loose connectivity. Restarting the server instances restores connectivity immediately.

Thanks,
Justin.
//Add this to "OnDomLoad" event