Service Desk Practitioners Forum
Showing results for 
Search instead for 
Did you mean: 

Cannot delete a View from the system.

Meine de Vries
Regular Collector

Cannot delete a View from the system.

When trying to delete an obsolete view the system indicates that there are relations left thus prohibiting this delete. See attached screen print.

The system complains about a relation with an 'Application Account'. For some 'default view'; however I don't even see how one can specify a default view for an account. I have even removed all the roles for the application account and the system will still not allow me to delete the view.

Also there appears to be a relation with something called 'Item'. I am totally lost on that one; I have no idea what that is supposed to mean.

Any suggestions,

Thanks, Meine

PS. We are running SD4.5, service pack 25.
Honored Contributor

Re: Cannot delete a View from the system.

Hi Meine,

Users can set the view they want as their default in their client (as long as the view is related to their role of course).

Now, if a user set that view to be its default view, then this was probably stored in its cache data, so maybe ask that user to login to SD and to use any other view as its default (View->Current view-> Define Views) then to logout and login.

Randall Barrantes
SW Support Delivery Manager
Meine de Vries
Regular Collector

Re: Cannot delete a View from the system.


thank you for your reply.

I have tried your suggestion and it did not solve my problem.

I would expect such information not necessarily to be stored on the server, but in the PC local USER.dat and/or Views.DAT files.

Thanks, Meine
Tommy Koronen_1
Regular Collector

Re: Cannot delete a View from the system.

I had a similar issue a long time ago.
It was caused by some "leftover" lines in the REP_JAVAOBJECTS table.

You can verify if this is the case by running the following SQL command:

select jav_oid from rep_javaobjects where not exists (select 'x' from
rep_view_title_infos where vti_jav_oid=jav_oid) and

This should normally return nothing.
But if you have the same issue that I had you will get 2 jav_oids?

In that case you might need to remove these jav_oids from the rep_javaobjects table.


Meine de Vries
Regular Collector

Re: Cannot delete a View from the system.


thank you for your reply.

I have run your query (adapted to reflect the location in servicedeskrepo) with the results listed below.

select jav_oid from servicedeskrepo.rep_javaobjects where not exists (select 'x' from servicedeskrepo.rep_view_title_infos where vti_jav_oid=jav_oid) and jav_entity=476381185


Are you telling me I should delete these rows from the servicedeskrepo.rep_javaobjects table?

I am not sure if I am totally comfortable with that, not really knowing the database structure and all it's relationships.

Also we do not have a 'test' environment for me to try this on. So I may have to hold off on this for a while.

Thanks again for your response, Meine
//Add this to "OnDomLoad" event