Service Desk Practitioners Forum
cancel

Advanced Find Filter does not work

Highlighted
Zeenath Aslam
Trusted Contributor.

Advanced Find Filter does not work

There are two filters for workgroup in Advanced Find
1)Shows the blocked workgroups
2)Shows the unblocked workgroups

Whichever view I select the search result shows all the blocked and unblocked workgroups irrespective of the selected view. Also when I select the unblocked workgroups view and search for a blocked workgroup, it shows.

Then what is the use of view in Advanced Find?
4 REPLIES
Richard Fredrik
Honored Contributor.

Re: Advanced Find Filter does not work

You can change this by selecting the following option in "general setting" of the "administrator console":
"Apply filter in advanced find, Quick find And Overview Action Results.

[see screenshot :)]

Can you please tell me if this solves your problem?

!!This option is not available in all sp's of SD !!
Zeenath Aslam
Trusted Contributor.

Re: Advanced Find Filter does not work

Thanks Richard.

Part of my problem is solved.

As I checked the option you suggested, the filter is effective when I give Find Now without giving any specific search code.

But when I try the same with a specific search code the filter is not effective.

Say I choose the blocked workgroups view and give the search code of a non blocked workgroup and search, it shows, which means the filter is not applied.

See the screenshot. There mentioned GL-HPSD is an unblocked workgroup.

Is there any way to solve this?

Richard Fredrik
Honored Contributor.

Re: Advanced Find Filter does not work

Yes, you're totally right that this is not working. From a functional view is also not recommended to make that possible.

Or the filter from the view is used, Or you custom made filter (in the advanced find) windows is used. not both.

The 2 options to accomplish what you want are:
1. Make a view that you call "search 1" and define in this view what you want to see in advanced find. Then when you open advance find, you select this view, and you press search. Now the proper results will be displayed because you have defined this in the view. (I recommend this one)

2. You can define the filter in the advanced find windows manually. This option is more suitable for searched that needs to be done occasionally. For the more often searches you can use option 1.
Ruth Porter
Acclaimed Contributor.

Re: Advanced Find Filter does not work

Hi there,

The option setting mentioned in the previous response will apply to ALL searches and so can have side effects you do not want.

A simple way that I use is whenever I block something with a searchcode I rename it as ZZsearchcode so that it is clear not to use it.

Hope this helps, Ruth

PS it is usual to assign some points when someone responds

http://www.teamultra.net