Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel

iLo-3 - my 1st impressions - highly unstable and buggy

SOLVED
Go to solution
Highlighted
CD9
New Member.

iLo-3 - my 1st impressions - highly unstable and buggy

Having taken deliver of my brand new G7 this week, and "enjoying" the new iLo3 for the first time - I must say - what a shambles.

As always - first thing I did was move it off the default ports 80 and 443 (I don't want random net hackers easily probing my iLo thanks!!!). Well - that wasted a day of my time - none of the remote consoles function anymore if you change the default ports. What is the point of even have a page to let us change the ports, if doing so renders it all unuseable???

And on the subject of changing ports:-

curl *.*.*.**/robots.txt


Object Not Found


Object Not Found


The requested URL '/robots.txt' was not found on the HP iLO3.






The default behaviour for iLo-3 is to let google tell the entire planet how to find your servers console instantly... And if you take the time to read the firmware update notes, you'll notice that the most recent vulnerability was related to problems from specifically crafted incoming TCP packets - this, and google, are a hackers dream.

So after I've gone back to 80/443 (and the future mercy of google and hackers), I discover that when I log in as the new admin user I created (Again - I don't use the default "Administrator"), I find that remote console still doesn't work. Seems like more "hard coding" of "Administrator" is hiding in there someplace.

Next - I find out that various combinations of windows guests and java versions still don't give me a remote console.

Eventually - I find one with Java working...

The Java remote console is unuseable - the auto-repeat on keypresses is some dumb number of miliseconds - tapping a key as short as possible gives 2 or 3 repeats of the keypress.

Finally, after another day of screwing around, I discover that 1 out of my 4 workstations gives me the a .NET remote console that actually works (yay).

3 hours of support phone calls and 2 days effort - just to log in. There's also a massive annoyance with the firmware update stuff: the latest firmware is "1.10 August", but my iLo says it's got "1.10 July" - so the phone tec tells me to upgrade. Well - that alone blew away half a day - the iLo itself has a firmware update option, into which you need to supply the firmware .bin file - and every one of the dozen or so different links to this file leads to something that is not a firmware .bin file. The only way you can currently update the firmware, is to already have an operating system installed. Tough luck if, like me, you needed the iLo to install the OS to beging with...

Anyhow - I eventually figured out that you can download the firmware update .EXE program for windows, and use "winzip" to extract the files from the .EXE container, whereupon I find that the "August" firmware update contains an iLo rom image dated "July" - and the iLo won't update because it says it's already installed.

Shambles all the way.

And to rub insult into injury - I hit google asking for a way to report bugs, and I find other people like me submitting them on forums, and HP support staff telling them to pick up the phone and report them to someplace else.

What kind of employee, when looking at a problem in their own product, could not be arsed to pick up their finger and help solve the problem? We're not being paid to troubleshoot HP products - why is HP making us spend even *more* time trying hard to find how to tell the person who made all those mistakes about them???

This box cost me 600% more than a generic one; this is not how I expect to be treated!!

6 REPLIES
David Claypool
Acclaimed Contributor.

Re: iLo-3 - my 1st impressions - highly unstable and buggy

All I can say is that iLO (any version) is not intended to be placed unprotected on the Internet. Standard practice is to have it behind a firewall on a management or private network.
Oscar A. Perez
Outstanding Contributor.
Solution

Re: iLo-3 - my 1st impressions - highly unstable and buggy

iLO3 1.15 solves the remote console issue after changing port numbers from default values.
This version is being signed off as we speak and it should be available for download early next week.



__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
nVarona
New Member.

Re: iLo-3 - my 1st impressions - highly unstable and buggy

Virtual Power Button is buggy, does not power on the server on Momentary Press, and

Automatically Power-On Server on Power loss and Restart also.

 

Server Information:

HP Proliant ML110 G7

ILO Firmware 1.26 (Aug 26 2011)

 

Thanks,

nVarona

Oscar A. Perez
Outstanding Contributor.

Re: iLo-3 - my 1st impressions - highly unstable and buggy

We solved an issue related to the Virtual Power Button in iLO3 version 1.28. It was originally reported on blades but I believe it could happen on any platform.

 

Please try iLO3 1.28 and let me know if it solves your problem. Below are the FTP links:

 

Online ROM Flash Component for Windows x86
ftp://ftp.hp.com/pub/softlib2/software1/sc-windows-fw-ilo/p901462262/v75203

Online ROM Flash Component for Windows x64
ftp://ftp.hp.com/pub/softlib2/software1/sc-windows-fw-ilo/p1728391553/v75195

Online ROM Flash Component for Linux
ftp://ftp.hp.com/pub/softlib2/software1/sc-linux-fw-ilo/p1255562964/v73832




__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
arghya
New Member.

Re: iLo-3 - my 1st impressions - highly unstable and buggy

Virtual Power on iLO3 (DL380 G7) does not work  - Momentay Press button is useless and even "power on" from iLO SSH does not work...even on 1.28 version.

 

I am going with the earlier post - HP's quality and support quality has gone down in multiples since 2001 (which is when I started working with HP - PA-RISC servers and now mostly Intel based servers).

 

I am pushing my company to buy Dell (not sure if thats any better) servers in next round of hardware upgrades.

 

Arghya

Oscar A. Perez
Outstanding Contributor.

Re: iLo-3 - my 1st impressions - highly unstable and buggy

I just tested momentary press button on my DL380G7 with iLO3 1.28 and it works fine every time.  Please call HP support and log a case. There could be something specific about your setup that is preventing iLO from powering on the server. This needs to be investigated.




__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!