Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel

iLO2 remote console doesn't work

Highlighted
Sandra Iwamoto
Contributor.

iLO2 remote console doesn't work

When I try to use the remote console on a Proliant DL320s G1:

o Using the integrated remote console:

I see "Attempting to connect to iLO remote console.

After a bit, I see the tab with the icons for cntl-alt-del, virtual media, etc.

After a bit longer, I get this pop-up:

Network Status
Failed to connect to server.
Check for available telnet connection.
[OK]


o Using the Java applet-based remote console:

I get a window with text and buttons at the top, and the rest is white space, except for a beige bar about halfway down that says:

java.net.ConnectException: Connection refused: connect


Meanwhile, the virtual media applet works just fine.


Windows XP SP2
IE 6 SP2
J2SE Runtime Environment 5.0 Update 15
Java 2 Runtime Environment, SE v 1.4.2_13
Java(TM) 6 Update 15


This occurs on multiple iLOs. I yet found one on which this works.

I was able to access these iLOs in the past (some months ago). Since then, though, I've had to reimage my workstation and reinstall my apps, etc., so my client's changed since then, and this is the first time I've tried to access them since.


How can I get this to work?
8 REPLIES
Jimmy Vance
HPE Pro

Re: iLO2 remote console doesn't work

Sounds like there is a firewall blocking ports between your workstation and the servers. With the re-image of your workstation, was some type of firewall/internet security package installed?




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
pratap m keshav
Honored Contributor.

Re: iLO2 remote console doesn't work

You can check if the port 23 (telnet) is open. Remote console requires this port to be available. You can check if any firewall is blocking port 23.
Sandra Iwamoto
Contributor.

Re: iLO2 remote console doesn't work

Hi Jimmy, Pratap,

Thanks for your responses. My workstation was reimaged with PC-COE/XP. Whatever firewalling is or is not present is based on that.

How would I find out if there's a firewall blocking port 23/telnet?

One thing I've tried is that I'm successfully able to run puTTY on my Windows workstation and telnet to a server and log in. So, if the firewall you're asking about is applicable to my workstation overall, not IE specifically, then there doesn't appear to be one blocking port 23/telnet.


Cheers,

Sandra
pratap m keshav
Honored Contributor.

Re: iLO2 remote console doesn't work

You can try to launch iLO from a machine having just JRE 1.4.2 or JRE 1.5. I guess latest JRE (or recent update) might be causing problem to launch.

Even if we can install multiple JRE's on a machine, it may not be good idea to use older JRE version for a particular application, due to security reason. New JRE might have fixed some critical security hole.

I suggest to use a client with older JRE (1.4.2) and check if the problem persists. If this works, the client may be used to launch just the iLO web interface.
Sandra Iwamoto
Contributor.

Re: iLO2 remote console doesn't work

Hi Pratap,

Just to clarify, given the following installed software:

J2SE Runtime Environment 5.0 Update 15
Java 2 Runtime Environment, SE v 1.4.2_13
Java(TM) 6 Update 15

Am I correct in understanding that you're recommending I remove this:

J2SE Runtime Environment 5.0 Update 15

and leave these:

Java 2 Runtime Environment, SE v 1.4.2_13
Java(TM) 6 Update 15


Cheers,

Sandra
Sandra Iwamoto
Contributor.

Re: iLO2 remote console doesn't work

Hi Pratap,

Thanks for your help. As it turns out, the problem was with my ability to access port 23/telnet, as you and James had initially indicated. One of my teammates helped me resolve this.

Background: The iLOs I'm trying to reach are on a private network. To reach them, we need to proxy the connection through a server that's on the "regular" HP 15/16 network and the private network. The way we do this is:

o Open a puTTy session to the server that's on both networks.

o Configure two ssh tunnels for this connection: one for port 443/https, one for port 23/telnet.

o Using an IE browser, connect to https://localhost:; e.g., if the local port was 9443, it would be https://localhost:9443.

This allows me to access the remote console if I use the Java-based applet; it doesn't work for the integrated console, because it doesn't use the proxied connection.


Cheers,

Sandra
Jimmy Vance
HPE Pro

Re: iLO2 remote console doesn't work

Here is a list of all the iLO ports when your doing port forwarding with putty

PORTS:

Port Description
22 Secure Shell (SSH)
23 Remote Console / telnet
80 Web Server Non-SSL (HTTP)
443 Web Server SSL (HTTPS)
3389 Terminal Services
17988 Virtual Media
9300 Shared Remote Console
17990 Console Replay
3002 Raw Serial Data

If your doing it from a *NIX system the command line is like so

(the listed string is one continuous line)

ssh -L 22::22 -L 23::23 -L 80::80 -L 3389::3389 -L 443::443 -L 17988::17988 -L 17990::17990 -L 9300::9300 -L 3002::3002 username@ssh_host.system

Launch your browser and enter https://localhost

You will be presented with your iLO login screen.




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
YasharSaatchi
New Member.

Re: iLO2 remote console doesn't work

It was solved.

port number 23