Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

iLO Management Interface Driver for Windows x64 Version Discrepancies

Highlighted
zpetersen
Acclaimed Contributor

iLO Management Interface Driver for Windows x64 Version Discrepancies

So, I'm working on an Exchange 2007 deployment using BL480c and BL460c servers which all utilize iLO2. When I run the Exchange Best Practices Analyzer I get the following warning:

"The version of 'CPQCIDRV.SYS' installed on server iacedmbx1.mcld.net can cause kernel memory allocation errors. An update is available from the vendor. Installed version of 'CPQCIDRV.SYS': 1.12.0.0."

Sure enough the driver file on the server shows the version that the Exchange Analyzer detected. After a bit of research I found the following update/advisory on hp.com:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c00688313&jumpid=reg_R1002_USEN

It directed me to a download for an "updated" version of the iLO mgmt driver. The problem is its the same version that I have. I looked a bit more and found this page:

http://h18007.www1.hp.com/support/files/server/us/revision/8610.html

After looking over that document I am confused. What is the real "current" version. According to the version numbering 1.9.3790.0 from 31 Aug 06 should be the most current version. However, you can see that the "name" of the download is different. Some say "for Windows x64 Editions" and others say "for Windows Server 2003 x64 Editions"

Questions are.. who's right? Whats the current version? Why the confusing version scheme? Or.. am I just crazy?
3 REPLIES
zpetersen
Acclaimed Contributor

Re: iLO Management Interface Driver for Windows x64 Version Discrepancies

I'm working with an HP engineer to get this straightened out. After discussing this with him the common belief is that the version numbers seem to go down due to the change from iLO to iLO2.

Because the Exchange Best Practices tool reaches into the registry and simply grabs the version number of the the iLO package it doesn't take into account the fact that iLO2 is running on the server and is the most current version.
Oscar A. Perez
Esteemed Contributor

Re: iLO Management Interface Driver for Windows x64 Version Discrepancies

Maybe the Best practices analyzer is not detecting the version correctly.
It is easy to get confuse with this version numbering scheme anyway.

In this case, the Driver version 1.12 is > than version 1.9 (or version 1.09 if you want)



__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
acartes
Honored Contributor

Re: iLO Management Interface Driver for Windows x64 Version Discrepancies

Oscar is correct. Running version 1.12 addresses the problem:
"Installed version of 'CPQCIDRV.SYS': 1.12.0.0."

There is a gremlin in the best practices analyzer that is flagging this case. The version numbers do increase in subsequent releases.

The driver revision history page page:
http://h18004.www1.hp.com/support/files/lights-out/us/revision/8610.html
Shows 1.12.0.0 (25 July 07) as the latest, and 1.9 is not even listed (it was probably redacted)
//Add this to "OnDomLoad" event