Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual Serial Port Unresponsive/Unusable

Highlighted
JonU
Occasional Advisor

Virtual Serial Port Unresponsive/Unusable

Hello,

I have a large number of ProLiant DL360 G3 servers running Windows Server 2003 Standard Edition that I am trying to configure to use VSP redirection with the help of Windows EMS.

Here is what I have done:

1. I enabled EMS in the OS using the BOOTCFG tool (exact command syntax: BOOTCFG /ems on /port com1 /baud 9200 /id 2) and rebooted the server.

2. I enabled EMS in the RBSU (BIOS) following the instructions in the ILO HowTo guide for servers that are running a BIOS in fixed IO mode (enabled EMS console in Remote mode; disabled the BIOS serial port console; set BIOS serial console baud rate to 115200; set Terminal Emulation Mode to VT100).

3. I configured ILO at boot time (F8) to reflect the configuration I wanted (ip address, user accounts, etc.).

Then I allowed the server to boot up and I accessed its ILO interface via a web browser.

I had no trouble logging into the ILO browser interface or accessing the virtual power options.

When I lauch the Virtual Serial Port applet I receive the following message:

Virtual Serial Port active: IO=Ox0408 INT=4

but when I click on the applet and press enter (or any key sequence for that matter) nothing happens; no SAC> prompt is displayed and the window is completely unresponsive.

I am having this problem for all of my DL360 G3 servers which are running a fixed IO mode BIOS. My DL360 G4 and G4p servers work perfectly and I can get to the SAC> no problem by following the instruction in the ILO HOWTO guide.

Does anybody have any thoughts on this?

Thanks in Advance,

Jon
3 REPLIES
JonU
Occasional Advisor

Re: Virtual Serial Port Unresponsive/Unusable

Sorry guys- in my post above, I meant to type


"BOOTCFG /ems on /port com1 /baud 9200 /id 1"

not "id /2"

Thanks,

Jon
JonU
Occasional Advisor

Re: Virtual Serial Port Unresponsive/Unusable

Any ideas on this guys??

Thanks,

Jon
acartes
Honored Contributor

Re: Virtual Serial Port Unresponsive/Unusable

The DL360 G3 servers use virtual serial port (VSP) parameters that are "non-standard". That is, COM1 and COM2 map to "standard" I/O addresses, but the VSP does not (the 0x408).

Later servers allow VSP to use standard resouce assignments which avoid the hassle.

Specifing:
BOOTCFG /ems on /port com1 /baud 9200 /id 2
tells the OS to override the EMS binding from the current(*) assignment to use the standard COM1 assignments.

(*) the current EMS assignment is received by the operating system from the system BIOS configuration using data expressed in ACPI tables. For ACPI background, consult Microsoft.

The VSP on DL360G3 does not map to COM1, so effectively the BOOTCFG statement disconnects EMS and the virtual serial port.

I think if your BOOTCFG statement does not expressly specify COM1, it will bind to the current VSP values as configured in host RBSU.
You may want to omit BOOTCFG altogether, as EMS should activate because it is expressed in ACPI.
//Add this to "OnDomLoad" event