Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Using iLO license key turns on two-factor auth?

SOLVED
Go to solution
Highlighted
Nate Sternberg
Acclaimed Contributor

Using iLO license key turns on two-factor auth?

I have several Proliant servers running iLO firmware 1.43. Once, I needed to access the graphical remote console, so I entered an eval license key. I did my work, and logged off.

But apparently, entering the license key also turns on two-factor authentication (?!) So now when I attempt to log back in, it requests a cert, but I haven't uploaded any certs to trust. So I appear to be locked out. So my questions are:

1) Is there any way to get back in to the server, other than flipping the security override switch on the chassis?
2) Is this really how it's supposed to work (entering an eval key activates two-factor auth)? Or is something else going on that's turning it on?
4 REPLIES
KarloChacon
Frequent Visitor
Solution

Re: Using iLO license key turns on two-factor auth?

acartes
Honored Contributor

Re: Using iLO license key turns on two-factor auth?

>> But apparently, entering the license key also turns on two-factor authentication (?!)

2-factor requires a license key, but a license key does not activate the support without prior configuration.

>> Is there any way to get back in to the server, other than flipping the security override switch on the chassis?

Karlo pointed-out some options. However the network-based method for RIBCL is closed if 2-factor is active, so that may not be an option.
Nate Sternberg
Acclaimed Contributor

Re: Using iLO license key turns on two-factor auth?

Thank you Karlo and acartes! Hitting F8 during the boot process and disabling 2-factor auth from the console worked.

acartes, it's strange that entering an activation key is not supposed to enable 2-factor auth. It seems to do so quite reliably for me. Can settings like that get set to "on" even before the feature is activated? If so, that might explain my case...
acartes
Honored Contributor

Re: Using iLO license key turns on two-factor auth?

>> Can settings like that get set to "on" even before the feature is activated? If so, that might explain my case...

I would guess that some deployment scripts are being run that are installing 2-factor parameters. This setting is inert until a license key is later installed.
//Add this to "OnDomLoad" event