Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

RIB.cpl (Control Panel Admin ICON) does not work with iLo

Highlighted
euan walsh
Acclaimed Contributor

RIB.cpl (Control Panel Admin ICON) does not work with iLo

Using the RIB.cpl control panel applet with a iLo board on a G3 the error "Remore Insight Board Driver is not responding. Verify that CPQRIB is installed and running" is displayed.
Is there an updated RIB.cpl for support of the iLo.
I dont want to use the CPQLOCFG DOS utility.
Thanks
7 REPLIES
Junior Yharte
Frequent Visitor

Re: RIB.cpl (Control Panel Admin ICON) does not work with iLo

The applet was for RILOE only and will not work for iLO. There are no updates planned at this time for iLO support. There are currently 4 ways to make changes to the iLO config, F8, CPQLODOS, CPQLOCFG, and the web page. Is there something specific that you need to get done from the server itself?
Roberto L Moral
Acclaimed Contributor

Re: RIB.cpl (Control Panel Admin ICON) does not work with iLo

Can you send me the RIB.cpl file?
My email is robmor110678@hotmail.com
Thanks!
Jeff Price_3
Acclaimed Contributor

Re: RIB.cpl (Control Panel Admin ICON) does not work with iLo

I would also like to see a iLO version of the old rib.cpl tool. I have a scenario where a critical system in a remote location had its iLO user list messed up by rib.cpl. We cannot afford an outage for site staff to pop the lid and flick the iLO reset switch.

Jeff.
Brian Williams_
Acclaimed Contributor

Re: RIB.cpl (Control Panel Admin ICON) does not work with iLo

In more organization we use hundreds of Compaq/hp servers using RILOE, RILOE-II, ILO. RIB.CPL was only for RILOE; however we have successfully used it "sometimes" on RILOE-II's. I don't know why it works but sometimes it does - other times it says that it can't find sm2user.dll and asks me to install the management agents. Of course they are already installed on everything. Furthermore, I should mention that when RIB.CPL does work on RILOE-II's it's functionality is VERY limited. I think we can only set the IP, Subnet Mask, and *possibly* the user account. But you cannot set the Gateway address or change the nic to FULL DUPLEX. You can choose between DHCP and a hard IP as well as change from 100Mbps to 10Mbps. I have read the response by the "Junior Yharte" and he claims there are 4 ways to make changes on an ILO and he is correct - however F8 requires physical access, and the other 3 methods mean the ILO has to be ALREADY configured!!!! But THAT IS the problem. Some of our ILO's are not configured!! We have servers all over the place and often times we don't have server Admins in those locations that can be available outside of our hours of operation! It is very difficult to get with a user after 7pm and try to walk them through blindly setting up a remote board. Another interesting note about ILO's is that gateway addresses are far more important than they are on RILOE's and RILOE-II's. I don't know why this is but, in our network we use something called HSRP gateway addresses that allow switch redundancy for our teamed NICs on our servers. However, an ILO must be configured for the correct gateway before you can connect to it - even though you may already be able to ping it.
Well, I thought I would do a brain dump on remote boards since I've used them a lot. In any case, I think it is a WRONG to not be able to remotely configure these boards through the OS. I am petitioning HP/Compaq to reconsider this position - it has been a real PITA for our organization when we went through our servers trying to verify remote board connectivity and we couldn't even try a different IP on server that were not responding.
Gotink
Regular Collector

Re: RIB.cpl (Control Panel Admin ICON) does not work with iLo

I fully agree with Brian!
Why no user modification of the rib by the control panel?
David Vekemans
Occasional Advisor

Re: RIB.cpl (Control Panel Admin ICON) does not work with iLo

Hello all,

Still no news for an eventual update of RIB.cpl for ILO ?

Thanks

David
tony_211
Acclaimed Contributor

Re: RIB.cpl (Control Panel Admin ICON) does not work with iLo

Thank a lot for your response
I find my Probleme, I just reset my card in the RIB's script and all thing is right now.
I use CPQLOCFG (last version) and compatible script for ILO and RILOE II.

Thank
//Add this to "OnDomLoad" event