Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Pull Network configuration/Pwd/username of ILO/RILOE on servers(400)

Highlighted
Aruselva
Acclaimed Contributor

Pull Network configuration/Pwd/username of ILO/RILOE on servers(400)

We have set of servers in which ILO/RILOE 'has been/might not been' configured.Now I have an task of updating my documents with the IP address,Mac adress,username,password of the ILO/RILOE I/RILOE II(which ever is configured in my server).Which i think will take my life for a month, if i do it manually.Is there any script/tool to achieve this ?
8 REPLIES
KarloChacon
Frequent Visitor

Re: Pull Network configuration/Pwd/username of ILO/RILOE on servers(400)

Aruselva
Acclaimed Contributor

Re: Pull Network configuration/Pwd/username of ILO/RILOE on servers(400)

Thanks a lot Karlo for your quick response,

I have tried using the scripts using the CPQLOCFG .I got the below error.Could you please have a look on that.

>CPQLOCFG.EXE -s 144.131.133.48 -u Admin -p Password -f get_network.xml

CHECKING XML SYNTAX...
START_OPEN_TAG
RIBCL
VERSION
EQUALS
2.0
END_TAG
START_OPEN_TAG
LOGIN
Overriding credentials in script with those from command line.
USER_LOGIN
EQUALS
user1
PASSWORD
EQUALS
password
END_TAG
START_OPEN_TAG
RIB_INFO
MODE
EQUALS
read
END_TAG
START_OPEN_TAG
GET_NETWORK_SETTINGS
CLOSE_OPEN_TAG
START_CLOSE_TAG
RIB_INFO
END_TAG
START_CLOSE_TAG
LOGIN
END_TAG
START_CLOSE_TAG
RIBCL
END_TAG


Valid XML Syntax

Connecting to Server..
Negotiated cipher: 168-bit Triple DES with RSA and a SHA1 MAC
SIO_connect failure.
Please check log file for more information.
CPQLOCFG.EXE: ERROR: SIO_connect:reason(10061).

In the above syntax is run locally using the ipaddress of the same server.If i dont add the server ip ,it does not work.The above error might be due to the incorrect user name and password.This is the problem i face in all servers , i have no record of this username and password of ILO's.Here i would really feel silly but no go to ask this , So is there any script to reset the passwords in all the cards irrespective of ILO/ILO 2/RILOE I/RILOE II other than restarting the server and reseting from BIOS.?

KarloChacon
Frequent Visitor

Re: Pull Network configuration/Pwd/username of ILO/RILOE on servers(400)

that cpqlocfg is to use across network

C:\ilo_conf>cpqlocfg.exe -s 16.90.x.x -u Administrator -p Password -f Get_N
etwork.xml -l information.txt


that one above is working fine for me
XP machine and logging all information in a file named information.txt

just in case run it again and add as I did -l filename.txt and check what message you got
since it can tell why is not connecting bad user, bad password ....

bye

Didn't your momma teach you to say thanks!
Aruselva
Acclaimed Contributor

Re: Pull Network configuration/Pwd/username of ILO/RILOE on servers(400)

I have done the following.

1) Logged in to nearest server(as we cannot connect from my local sys xp)
2) tried the command with the -l option included.
3) It throwed the same error.

Please find below the error messsage,that was present inside the infomation.txt

IP Address is: 144.131.133.48
SIO_connect failure.
39220:error:0200274D:system library:connect:reason(1869):.\crypto\sio\s_sock.c:6
06:host=144.131.133.48:443
39220:error:10065068::lib(16) :SIO_CONNECT:connect error:.\crypto\sio\s_sock.c:6
08:
CPQLOCFG.EXE: ERROR: SIO_connect:reason(10061).

I did not understand what it is pointing to ..
KarloChacon
Frequent Visitor

Re: Pull Network configuration/Pwd/username of ILO/RILOE on servers(400)

you can see it refers SSL-> port 443

can browse that server ? using SSL-> https

I mean https://144.131.133.48


also which server is that one?
which ilo and firmware version?

bye
Didn't your momma teach you to say thanks!
KarloChacon
Frequent Visitor

Re: Pull Network configuration/Pwd/username of ILO/RILOE on servers(400)

just to let you know

I changed ssl port in my ilo web settings to 445 and I got the this error

IP Address is: 16.90.x.x
SIO_connect failure.
3280:error:0200274D:system library:connect:reason(1869):.\crypto\sio\s_sock.c:606:host=16.90.108.187:443
3280:error:10065068::lib(16) :SIO_CONNECT:connect error:.\crypto\sio\s_sock.c:608:
cpqlocfg.exe: ERROR: SIO_connect:reason(10061).


similar the one you got
so you have to options in case is your case
log to ilo web browser and chage ssl to 443 (default) or add the SSL port for your ilo int he script above ip:445

cpqlocfg.exe -s 16.90.x.x:445 -u Administrator -p Password1 -f G
et_Network.xml -l information.txt



Didn't your momma teach you to say thanks!
Jimmy Vance
HPE Pro

Re: Pull Network configuration/Pwd/username of ILO/RILOE on servers(400)

to use cpqlocfg you must have a valid username/password as it is connecting to iLO across the network. You can run hponcfg locally and a valid username/password is not required. To use hponcfg the iLO channel driver must be running on the server.

Regardless, non of the data returned will provide you with the current passwords, just the usernames. Using hponcfg you can reset the default Administrator password to what is on the toe-tag, or set the Administrator password to something you want.

To get all the data your looking for you can combine the XML from several of the Get* scripts so all the output goes into one file.



In the example script package Karlo mentioned

Administrator_reset_pw.xml
Change_Password.xml

Using hponcfg this line needs to be in the XML file



Used locally with hponcfg the username and password don't need to be valid, but the line must exist in the XML.




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
acartes
Honored Contributor

Re: Pull Network configuration/Pwd/username of ILO/RILOE on servers(400)

The error described in the original post:

Connecting to Server..
Negotiated cipher: 168-bit Triple DES with RSA and a SHA1 MAC
SIO_connect failure.
Please check log file for more information.
CPQLOCFG.EXE: ERROR: SIO_connect:reason(10061).

This indicates an SSL handshake error. The connection fails before the credentials or script are processed.

Possibilities:
1) iLO is configured to use an HTTPS port other than 443
2) the IP address you specified is not iLO but another network device
3) try the script against a "known good" iLO network address
//Add this to "OnDomLoad" event