Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Powershell HPIOLO Hostname??

Highlighted
CurtA
Acclaimed Contributor

Powershell HPIOLO Hostname??

Hello,

While trying to figure out how to use the HPE Powershell commands on iLO 4 (FW version 2.44) I have come across a weird issue.  Some of my Proliant ML310 servers will refuse to let any remote configuration take place due to it not being able to resolve a hostname (which looks similar to: dt-00c297edbfe).

Using the Get-HPiLOServerInfo and Get-HPiLONetworkSetting commands I see a property called HOSTNAME that is set to this weird name.  Unfortunatly, I can not find where to change this setting.  There is no PS command, place in the Advanced Settings, or in the iLO configuration where I can change this.  The closest I have found is in the iLO -> Network -> Shared Network Port - > General -> iLO Hostname Settings -> iLO Subsystem Name (Hostname).  However, that is set correctly and doesn't seem to affect this other HOSTNAME.

Everything I've found online (not much out there, either) says that this is just another name for the DNSName.  However, changing the DNSName (via the interface or the PS command) doesn't seem to affect this HOSTNAME.

Sometimes (not always), I can get it to clear out by performing multiple factory resets.  This doesn't aways work, however.

Any ideas on what this is and how I can change it?

Thanks!

3 REPLIES
CurtA
Acclaimed Contributor

Re: Powershell HPIOLO Hostname??

I guess I'm the only HP customer with this issue, then?

rookie1082
Acclaimed Contributor

Re: Powershell HPIOLO Hostname??

If you're referring to the ILO hostname then it's in the set-hpilonetwork setting cmdlet I believe.

Can u show a screen shot?
GokulKS
Super Collector

Re: Powershell HPIOLO Hostname??

Hi,

You need to use Set-HPiLONetworkSetting  with DNSName as input parameter for changing the hostname.

Set-HPiLONetworkSetting -DNSName 

Pelase update me on the same thread if you could solve the issue with the above cmd.

Thanks,

Gokul

 

//Add this to "OnDomLoad" event