Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel

Link ILO2 to AD fails when server name starts with number

Highlighted
Peter Galando
New Member.

Link ILO2 to AD fails when server name starts with number

I am seeing a failure on the "Directory Server DNS Name" test when I use a domain controller whos name start with numbers (01hpserver) the errors given is:

Initiating Directory Settings diagnostic for server 01hpserver
Unable to resolve host name 01hpserver
Ceasing tests.
Some diagnostics FAILED for server 01hpserver

I have used the LDP.exe tool recommened by Microsoft to verify that LDAPS is working using port 636 and the hostname (01hpserver)
http://support.microsoft.com/kb/321051

Same results if I use the domain controllers long name.

The same behavior is seen on multiple DL-320 G5's with ILO2 firmware 1.29
2 REPLIES
Peter Galando
New Member.

Re: Link ILO2 to AD fails when server name starts with number

Just upgrade to 1.30 which released earlier in the week, same result...

Initiating Directory Settings diagnostic for server 01hpserver.intra.xxx.org
Unable to resolve host name 01hpserver.intra.xxx.org
Ceasing tests.
Some diagnostics FAILED for server 01hpserver.intra.xxx.org

I can ping and nslookup that name without issues from any host on the internal network.
acartes
Acclaimed Contributor.

Re: Link ILO2 to AD fails when server name starts with number

The error:
cannot resolve host name 01hpserver.intra.xxx.org
Indicates that iLO could not perform a DNS lookup of the directory server.

- check the iLO network settings to see if the DNS server stored there is valid
- use nslookup to determine which DNS server resolves the address, and try making this the first DNS server in the iLO list
- try configuring iLO with the IP address of the directory server and re-run the tests.