Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

ILO keyboard not working

SOLVED
Go to solution
Highlighted
Douglas Carlyle
Acclaimed Contributor

ILO keyboard not working

We have experienced a situation where the keyboard on an ILO remote console does not work (DL380 G3, W2003 server, ILO Firmware 1.80)
Looking in devices in computer management there is no keyboard device. Using a local Ps/2 connected keyboard does not work, a usb connected keyboard works. After rebooting the server the keyboard device reappears even with no keyboard connected locally. Can anyone help please, rebooting a production server frequently isn't an option.
3 REPLIES
acartes
Honored Contributor
Solution

Re: ILO keyboard not working

The absence of a keyboard may have been caused by the removal of a PS/2 keyboard originally present at boot. Since PS/2 keyboards are not inherently hot-pluggable like USB keyboards are, it will be difficult to add one again in this state. Generally, if it connected and the OS is up, the PS/2 keyboard should remain in place.

That being said, iLO mimics a PS/2 keyboard if none is present during POST. This is why the OS can now see one.

I do not think that you will return to this state unless someone keeps connecting/disconnecting a PS/2 keyboard to the host. iLO provides the ability to hot-plug a PS/2 keyboard (only once) per boot.
Douglas Carlyle
Acclaimed Contributor

Re: ILO keyboard not working

Acartes,

Thank you for your reply, your answer makes sense as we normally run our servers without a local keyboard or mouse but occasionally connect a local keyboard and mouse when working in the data centre. Based on what you advise using a USB keyboard for local connection should avoid such an issue in future.
Martin_266
Acclaimed Contributor

Re: ILO keyboard not working

More iLo info (not a solution): We use a non-HP keyboard and found it would not work with the ML370. After much frustration and research, found out why:

iLo checks for the presence of a keyb on startup -- if it doesn't see one it assumes you're running the server exclusively via iLo and disables the keyb port as a security measure.

This particular keyb and iLo don't get along on startup; we could start the server with a different keyb and then switch to the original once the machine started up.



Martin

//Add this to "OnDomLoad" event