Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel

ILO User Logon Name

Highlighted
RSHULTZ
Acclaimed Contributor

ILO User Logon Name

Is it possible to use the User Logon Name with schemaless directory integration for ILO? I can use LASTNAME\, FIRSTNAME but this has to be the most ridiculous format to enter in login information. Any suggestions? Thanks.
8 REPLIES
Rajeshwari, Hir
Frequent Visitor

Re: ILO User Logon Name

It is possible to use the login name with schemaless directory in the following formats ...
1. loginname@domain format
Ex: mylogin@mycompu.com
2. Netbios name
loginname\domain.
Ex: mylogin\mycompu.com
pratap m keshav
Frequent Visitor

Re: ILO User Logon Name

In order to use the Netbios or @domain format you need to configure directory settings in the following way.

In directory settings page use domain name of Active directory server instead of IP. Make sure you have entered proper user context.

In Network settings page use the IP of Active directory server in one of the "DNS server" fields and also fill the ILO subsystem name and domain name fields approriately.
RSHULTZ
Acclaimed Contributor

Re: ILO User Logon Name

I have attempted both of those methods and neither work to authenticate the logon name. Even if I put the actual DC and use the logon name as the cn it does not work look at the sample below:

Works:
CN=Shultz\, Ryan,OU=Admins,DC=company,DC=com

Does not work:
CN=rshultz,OU=Admins,DC=company,DC=com

I don't know what I am missing to get the logon name to work instead of just the common name.

Re: ILO User Logon Name

If "rshultz" is the login name,please try the
following.

1.loginname@domain.com
Ex : rshultz@company.com
2.Netbios name
loginname\domain
Ex : rshultz\company.com




pratap m keshav
Frequent Visitor

Re: ILO User Logon Name

A small clarification
for Netbios name you need to use domain\username format
eg: company\user

ActiveX controls should be enabled on the client machine
RSHULTZ
Acclaimed Contributor

Re: ILO User Logon Name

I have attempted these methods to no avail. The only thing I can login as is "Shultz\, Ryan" with the user context of @domain.com and nothing else works. I cannot use the samaccount name or upn. I cannot quite figure out what the issue is. Why can I use one but not the other. Is this an issue with AD and I am barking up the wrong tree? Thanks.
acartes
Honored Contributor

Re: ILO User Logon Name

... an understanding of how it works might help indicate a cause:

When you login using schemaless directory support, an ActiveX script on the iLO login page runs in your browser and attempts to determine the distinguished name of the user account entered in the login box.

For this to work:
1) ActiveX needs to be turned on and "Safe for scripting" needs to be enabled.

2) the client system (the one running the browser) must be able to access the directory.

3) the directory server name configured in iLO must be stored as a DNS hostname or name of the domain instead of an IP address.

4) The client should be able to ping the domain controller using the hostname of the directory server as it is configured in iLO.

Again, these requirements allow you to forgo using a distinguished name in the login box.
RSHULTZ
Acclaimed Contributor

Re: ILO User Logon Name

I discovered this after looking into the issue more. Thanks for the assistance. I must have either bypassed it altogether in the information and manuals for the iLO or it is yet another crucial yet undocumented item. Thanks again.
//Add this to "OnDomLoad" event