Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

ILO 2 Remote Console

Highlighted
DerCo75
Occasional Contributor

ILO 2 Remote Console

I can connect to the ILO2 of one of our Proliant DL380 G5 severs but the Remote Console interface is not working.The screen will show up OK but it does not respond to the mouse or keyboard.

I have already upgraded to the latest version of Firmware and reset and reconfigured the ILO but the problem remains

Anyone have any ideas?
16 REPLIES
SMR
Occasional Contributor

Re: ILO 2 Remote Console

Hi,

What browser/version are you using?

Are you using the integrated remote console(for IE)? or the java based remote console?

I assume you can't control the mouse or keyboard once you're at the OS login screen... maybe try using the keyboard during POST/RBSU and see if it works there?

Good luck!
Cederberg
Occasional Visitor

Re: ILO 2 Remote Console

Hi. Do you have the Proliant Support Pack Installed?

Particulary the HP ProLiant Integrated Lights-Out Management Interface Driver and HP ProLiant iLO 2 Management Controller Driver if using windows.
DerCo75
Occasional Contributor

Re: ILO 2 Remote Console

Thanks for the replies

@ SMH

What browser/version are you using?

Internet Explorer 6 but I have also tried on a PC running IE8 but have the same problem

Are you using the integrated remote console(for IE)? or the java based remote console?

I have used both

@ Cederberg

Support Pack 8.60 and Firmware 9.20 are installed
SMR
Occasional Contributor

Re: ILO 2 Remote Console

DerCo75,

Have you tried to control the server during POST?

I've seen this happen when people change/disable USB settings on RBSU/BIOS Setup. I'm not saying you did but is worth a shot to reset settings to factory defaults.

Cheers,
DerCo75
Occasional Contributor

Re: ILO 2 Remote Console

I can work on the server during POST. I went into RBSU and all USB settings were enabled
SMR
Occasional Contributor

Re: ILO 2 Remote Console

OK, maybe try resetting RBSU to defaults.
DerCo75
Occasional Contributor

Re: ILO 2 Remote Console

I don't think that is an option because the server is in one of our satellite offices and if I reset the ILO settings the IP Address will change and I will lose connection and leave the server in limbo
DerCo75
Occasional Contributor

Re: ILO 2 Remote Console

I tried reverting to factory settings through the ILO Online Configuration Utility but I still have the problem. Does it have to be done through RBSU?
Oscar A. Perez
Esteemed Contributor

Re: ILO 2 Remote Console

Does KB/Mouse work during POST? If so, then this is an OS driver issue.

iLO2 uses UHCI for virtual KB/Mouse. What OS are you running?

If you are running Windows then, open Device Manager, go to "View" menu and select "Devices by connection". Begin expanding until you find under one of the PCI buses a USB Root hub that has a USB Composite Device. (see attached pic)



__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
SMR
Occasional Contributor

Re: ILO 2 Remote Console

I meant the BIOS settings back to defaults. Although it really seems like an OS driver issue.
DerCo75
Occasional Contributor

Re: ILO 2 Remote Console

My server is running Windows 2003

None of the USB Root Hubs have a USB Composite device attached. It is the same for some of my other servers that don't have the problem.

Oscar A. Perez
Esteemed Contributor

Re: ILO 2 Remote Console

If you mount a virtual media ISO image, do you see a new USB device poping up under any of the USB Root Hubs?



__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
DerCo75
Occasional Contributor

Re: ILO 2 Remote Console

Just tried that. No difference however..
DerCo75
Occasional Contributor

Re: ILO 2 Remote Console

Problem solved....... sort of

It appeared that the problem with the ILO remote console was a symptom of a problem with the operating system in general as we developed a number of other problems with this server. We eventually cut our losses and re-built the server
Ali
HPE Pro

Re: ILO 2 Remote Console

Hi Derco,

agree!.. it might be OS issue.

However, remote console requires java runtime environment and plugins...

this issue generally observed when High performance mouse option is enable... disable high performance mouse (just a check box on remote console screen)

iLO 2 Firmware version 2.05 has lot fixes with reference to your issue.

if you have everything in place then best way to troubleshoot to check with another system to isolate..

Also Graphical remote console is licensed option

thanks
Aftab
I work for HP
Looking for a quick resolution to a technical issue for your HP Enterprise products? HP Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
DerCo75
Occasional Contributor

Re: ILO 2 Remote Console

Aftab,

Many thanks for your reply.

I had already tried disabling high performance mouse earlier (infact it was one of the first things I tried) but it made no difference.

The problem was definitely related to the USB drivers on the OS as when we brought the server back to the data centre, we plugged a USB keyboard directly into the server and it still would not work. It wouldn't even start in safe mode.
//Add this to "OnDomLoad" event